Почтовый клиент Evolution

Недавно обновил почтовый клиент Evolution с версии 3.36 до версии 3.46. В магазине была старая версия. Для начала сделал резервную копию данных и сохранил контакты в vCard через меню файл. Дальше сюда: Flathub—An app store and build service for Linux


I recently updated the Evolution mail client from version 3.36 to version 3.46. There was an older version in the store. To begin with, I made a backup copy of the data and saved the contacts in the vCard via the file menu. The link shows the Flathub packaging with the latest flatpak Evolution.

Is there a question here? Please do not post to Tutorials and Guides unless you are adding a tutorial or guide.

Evolution is a decent mail program (matter of opinion), available to everyone on a linux distrobution. Offering a link to the flathub is limiting, since a snap and .deb version are available.

I'm not understanding the point in this post?!

This may be partly due to the translation that I had added to the O.P. So I may be to blame for not being clear.

I tried to adhere as closely as I could to the original message but in translations, things can be lost.
The O.P. feels that the .deb stable package was not the latest package and was showing how to get the latest package using Flatpak.

There are good points and there are bad points to using flatpak, snap or the latest package over the current supported stable version.


Возможно, отчасти это связано с переводом, который я добавил к О.П. Так что, возможно, я виноват в том, что выразился недостаточно ясно.

Я старался как можно точнее придерживаться оригинального послания, но в переводах многое может быть потеряно.
О.П. считает, что .стабильный пакет deb не был последним пакетом и показывал, как получить последний пакет с помощью Flatpak.

Есть хорошие и плохие моменты в использовании flatpak, snap или последнего пакета поверх текущей поддерживаемой стабильной версии.

2 Likes

Version numbers be deceiving. You think you aren't getting the latest if the versions don't match across the board. One thing you must keep in mind is that both flatpak and snap may not be put together by the same team of developers. Being they are containerized applications, there will be updates for the container that are not necessary for the main application. This can be misleading when attempting to find the latest software. Look at the evolution webpage for the latest version number and info. The flatpak and snap variants will use the latest version.

This has been a confusion for many that are switching from windows. Though the concept is the same for containerized windows store applications verse stand-alone desktop apps. There are less issues in the containerized apps, which is why they don't realize that it is very much like a linux snap/flatpak.

The latest version numbers should not be your only motivation to update your system. This can cause issues, chasing software versions. You are currently using the 5.15.0.53 kernal....the latest is version 6. Updating to that will cause you all sorts of issues. Zorin developers use the latest stable version. You see how this is both complicated and a balance?


Номера версий обманчивы. Вы думаете, что не получаете последнюю версию, если версии не совпадают по всем направлениям. Одна вещь, которую вы должны иметь в виду, это то, что и flatpak, и snap не могут быть собраны вместе одной и той же командой разработчиков. Поскольку они являются контейнеризированными приложениями, для контейнера будут обновления, которые не нужны для основного приложения. Это может вводить в заблуждение при попытке найти новейшее программное обеспечение. Посмотрите на веб-страницу эволюции для получения номера последней версии и информации. Варианты flatpak и snap будут использовать последнюю версию.

Это было путаницей для многих, кто переключается с окон. Хотя концепция одинакова для контейнерных приложений Магазина Windows, стих автономных классических приложений. В контейнеризированных приложениях меньше проблем, поэтому они не понимают, что это очень похоже на snap/flatpak linux.

Последние номера версий не должны быть вашей единственной мотивацией для обновления вашей системы. Это может вызвать проблемы, преследуя версии программного обеспечения. В настоящее время вы используете 5.15.0.53 kernal.... последней версией является версия 6. Обновление до этого вызовет у вас всевозможные проблемы. Разработчики Zorin используют последнюю стабильную версию. Вы видите, насколько это и сложно, и сбалансировано?

2 Likes

Это было сделано, версии отличаются даже внешне. Спасибо за разъяснение. Но я мало что понимаю в этом, как вы могли заметить.-)

I, too, looked it up. the most recent stable version is 3.44. what is in the store and apt is 3.65. This is done by the developer to ensure as few issues as possible when updating users systems.

3.44 is available in a tar ball, a compressed file that contains the source code for you to compile and install yourself. Snap and flatpak devs do this and wrap it with the container (snap & flatpak respectively). Any issues that might arise from installing 3.44 will be mostly resolved, then it will be issued to the repository (sort of like beta testing).

Feel free to install 3.44, but you won't be missing anything but library updates, bug fixes... I didn't see any new features or compatibility improvements during my search. Personally, I'd wait until the package repository is updated (apt). I don't care for containirized apps.


Я тоже просмотрел. самая последняя стабильная версия 3.44. то что есть в магазине и апт это 3.65. Это делается разработчиком, чтобы обеспечить как можно меньше проблем при обновлении пользовательских систем.

3.44 доступен в виде tar-шара, сжатого файла, который содержит исходный код, который вы можете скомпилировать и установить самостоятельно. Разработчики Snap и Flatpak делают это и оборачивают контейнер (соответственно Snap и Flatpak). Любые проблемы, которые могут возникнуть при установке 3.44, будут в основном решены, затем они будут отправлены в репозиторий (что-то вроде бета-тестирования).

Не стесняйтесь устанавливать 3.44, но вы не пропустите ничего, кроме обновлений библиотеки, исправлений ошибок... Во время поиска я не нашел никаких новых функций или улучшений совместимости. Лично я бы дождался обновления репозитория пакетов (apt). Я не забочусь о контейнеризованных приложениях.