Failed Installation

I have tried many times, but installation continues to fail. After tuning the installation application with errors, a reboot ends with "no bootable device". I have tried with both UEFI and Legacy boot in the BIOS. I have the EFI System Partition (ESP) as "/dev/sda1" and "/dev/sda2" available for the installation.

After installation using LVM (no encryption), the system says complete and restart. I remove the USB flash drive; then the PC cannot find a bootable device.

Hello there!

I am not using LVM, and unless you work in an environment where system encryption is necessary, I would recommend not using LVM. But in an effort to be at least somewhat helpful, I will post a screenshot of my Gparted.

This is how my partitions are, and my system boots just fine.

As you can see, under /dev/sda1, when I let the installer do its thing, it created a 500MIB Fat32 boot/efi partition. Then in the extended partition under /dev/sda2, it installed Zorin OS on the EXT4 file system.

BTW, make sure that you always have SECURE BOOT disabled in the BIOS whenever you are installing a Linux distribution, including Zorin OS.

Hi,

Did you set your bootloader installation to /dev/sda1 where your EFI partition is ?

1 Like

Yes. And the installer knows that Zorin is there, and asks to delete the HDD and install Zorin. But for some reason, it won't actually put any bootable files in the correct partitions!

Since you only have a primary partition, it looks more like mine:

(I added a swap partition manually after the installation)

I do not see a mount point for boot/efi in your Gparted.

Have you tried Boot repair?

Well, that would do it! If there is no Boot/EFI partition, thats why he can't boot. The boot loader must be contained there, with the files and everything. Sounds like the Zorin installer had a brain freeze.

I have tried the Boot Repair app in Zorin (ran from the USB). No change.

Boot repair has reinstalled grub-eft-amd64-signed.
After repair:
=> No boot loader is installed in the MBR of /dev/sda.
Sda2 says OS is Zorin OS 16

At my most recent attempt of starting the installer even sees Zorin and asks if I want to install Zorin along side Zorin (dual boot)!

OK, I checked, and you've paid for PRO, which gives you VIP access to the Zorin team for support.

Please follow the instructions provided in the email you got, which has your registration number in it, and use the contact link to get support.

Since you are having installation issues, and we haven't been able to help you solve it after 3-days at least now, I recommend using your VIP service you paid for, to get support from the Zorin team.

They being the actual developers of the software themselves, will be experts in installation, so at this juncture in time, they are your best bet.

1 Like

Your bootloader should be on sda1.

That is why grub can not find it

1 Like

So I finally got the bootup to work. I had to define a trusted boot file in the BIOS to allow the computer to boot in to Zorin. I can't understand why that wouldn't have been part of the installation .... but oh well. I am working faster now on Zorin than my laptop did on Windows!
Thanks to all for the support.

1 Like

It could have been your BIOS too, many BIOS have advanced security that it only allows the version of Windows that came pre-installed, to be run. Glad you got it working and enjoying Zorin OS 16 PRO! !!!WOOHOO!!! LOL :joy:

As well as not knowing about it... Thanks for sharing this as it may help others.

I think it is because this requirement depends on the BIOS of the system.

I have several laptops/desktops at home and only one that has such requirement is 3 years old Acer Swtch3. All other systems boot normally as long as the secure boot is off.

I think the OP used this, my laptop needed this as well.

1 Like