Files does not return any search results

Nautilus/Files does not return any search results. Not much to say:

  • ctrl-f
  • type terms (aim for the content)
  • no result returned, ever

Nautilus / Soubory 3.26.4
Zorin OS 15.3

Is Catfish File Search Installed?

It has not been installed. It is now. No change in Nautilus search behaviour.

I have to correct the issue: There is no issue to search for terms in filenames. No file is displayed, when searching for terms within the files.

I.e. I can find all php files, when searching for "php"
I cannot find files containing "<?php", although there are plenty of them in main dir and subdirs.

The file search from Files never has been able to search in the content of files - only strings within the file names.

Catfish is an XFCE (Zorin OS Lite) package that works with Thunar, not Nautilus.
I prefer to use Nemo FM, as it includes a good functioning search, with the best so far being in Nemo 5.

Education is Based on?

Education is available in Core and Lite. It is based on Ubuntu.

1 Like

I thought it only had a Single version based on Xfce.
Education is Gnome
and Education Lite is Xfce, Got it :joy:

1 Like

Well, the settings to search and the context text tells me that it should be able to search terms in files
Screenshot from 2022-10-04 21-34-11

Are you, the thread followers surprised about the new information on the in-file content search of Nautilus/Files, or did I obfuscate the issue (unintentionally) and confuse you?

Where is that dialog shown in the image of post 9? I can't find it.

Nevermind, I found it in the dropdown of the search box. And it does work for text files. I made a file with the word 'dog' and saved it as 'sample.txt'. The search found the file containing 'dog'. Yes I am surprised. Something new.

A second test shows it works for content of .odt files too.


What fixes have you tried?
e.g. sudo apt install --reinstall nautilus
Are you the primary user and did you install Zorin OS on the machine. In some cases, a secondary user cannot see search results for a different user even on the same install.
Is tracker disabled?

Dear Aravisian, thank you for the suggestion. I reinstalled Nautilus, no change in behaviour. I'm testing the simplest case: created a txt with sample text and I'm searching for it by searching the content. I'm a general user (not admin), when testing.

I did install the Zorin OS on the machine. Tracker is not known as a command in terminal and I cannot find any hints about it. It isn't any application either.

It's a daemon of Gnome Desktop, so /etc/xdg/autostart/trackerd

It can be installed or removed:

sudo apt install tracker tracker-extract tracker-miner-fs

sudo apt remove --purge tracker tracker-extract tracker-miner-fs

So, nothing there that could inhibit search results. Hmmm...

1 Like

Thank you.

I run a simpler sudo apt install tracker before reading your post and it offered me the tracker-miner-fs.

I'm restarting and see any effects.

Great! Now tracker is running

milan     2334  1.0  0.3 680888 32024 ?        Ssl  22:06   0:02 /usr/lib/tracker/tracker-store
milan     2335  0.6  1.8 1268796 146828 tty2   SNl+ 22:06   0:01 /usr/lib/tracker/tracker-miner-apps
milan     2341  3.0  1.6 2917708 132456 tty2   SNl+ 22:06   0:06 /usr/lib/tracker/tracker-extract
milan     2376 65.8  3.0 1420144 247872 tty2   SNl+ 22:06   2:12 /usr/lib/tracker/tracker-miner-fs
milan     4429  0.0  0.0  32184  1096 pts/2    S+   22:09   0:00 grep --color=auto tracker

and search results in Nautilus are fetched and displayed.

I wonder, why was not any indexing running on the machine. Some indexing had to run, mustn't? Or it was always running find?

That is a good question...
The tracking should come default on the install.
You may have been looking for ways to increase security after install (only you would know) that you did not know you disabled that feature at the time.
If you have not done anything of the kind since the install of Zorin OS- we may have a minor mystery on our hands.

Nah, I'm a linux user newbie (was much better years ago), but I'm not aware that I would temper any such features. Also, I'm not going to reinstall just to prove the installation was default :smile:

I ran apt install to download the tracker. So, I would not just deactivate the indexing feature, but I would uninstall it. I do not recall such actions.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.