First month using Linux after decades of using windows - My experience so far

Back in December, seeing the Steam Deck's desktop I was curious to try it out, and since I couldn't afford that device and SteamOS 3 wasn't released for other hardware yet, I decided to look into linux distros, being Zorin the first one I found and the one that made me more curious to try at first.

After doing a lot of research and trying many different things, I finally managed to successfully install a linux distro on my laptop a month ago, around the beginning of May, but it ended up being Linux Mint because I kept seeing that's the best for beginners. It was great, better than windows in some things, but probably lacking full compatibility with my laptop, since some things felt slower than on Windows and Wine was giving graphical problems that I couldn't see anyone else having. It was probably my fault in any way, but I saw that as the perfect excuse to try Zorin, since it visually looks better than Mint in my opinion and it was the distro I was gonna try originally.

After around half a month using it, so far I'm loving it: everything from its look to performance is a massive upgrade over what I had before. This laptop struggled to run Windows 10 nowadays, and 11 wasn't even supported, but the Core edition of Zorin runs REALLY fast, almost like when this laptop was new, if not even better, and if over the years it starts to slow down again, there's always the lite edition, so just switching from Windows to Zorin was enough to add a few more years to the life cycle of this laptop. And those problems I had with wine in Linux Mint don't happen in here, so I probably didn't set it up correctly in there, but Zorin having it as easy as pressing the install button to download and set up everything wine needs to work out-of-the-box is amazing for new users like me.

So far my experience with Zorin has been smooth and amazing on everything (running some windows games, connecting my laptop to my tv for a dual-monitor, downloading software from inside and outside the built-in software store, using linux alternatives to windows programs like libreoffice instead of microsoft office, etc.) and I would love to see this distro as the main system on the computers of more people, since it does not just work as good as Windows, but even better.

I only see 3 problems, and they are related to the built-in software store:

  • On my first boot after install, no programs showed up in there, and the search bar would always say there were no results found, not even for programs that it should find like firefox, vlc or obs. This was probably because my wifi connection wasn't configured at boot, but it still was weird because that problem happened AFTER setting up the internet connection. Ending the task from the system monitor and then opening it again was enough to fix it, so it's probably a problem for not having internet connection immediately after boot.

  • Trying to download any packages for the first time would give an error and show up a notification with a command I need to type in the terminal to fix it. It sounds easy, just copy and paste that into the terminal, right? Well, the command was the solution, but it didn't have the word "sudo" at the beginning of it, and it wouldn't fix anything without it. Eventually I found out about what's sudo and adding it to that command made the software store finally functional, but I think the word "sudo" should have been in the notification with the command in the first place, since it is directed to new users who most likely don't know what's that or what does it do

  • The 3rd problem is less of a problem and more of an unintuitive progress bar. When installing anything from there, it usually gets stuck at 0% of progress and then starts advancing after a while. After installing a few programs I noticed that the time it takes to start moving becomes longer if the size of the program is bigger, so my theory is that, while it's on 0% of progress, what's doing is first downloading it and then it starts installing and actually making the progress bar advance. This can be understood, but at first glance it just looks and feels like there's something wrong with the software store, the computer or the internet connection, since there's no hint of it doing something. For future updates, I would suggest having something like a text saying "downloading" or even the progress of the download instead of having the first part stuck at 0% for a while as a way to make it more intuitive. That's if my theory of downloading while being stuck at 0% is correct. If it's another thing, making it possible to see what's going on would still help make it more intuitive.

To keep this short for those who don't feel like reading all this: Zorin is an amazing alternative to Windows, does what it promises to do, works really good, ready to use out-of-the-box with little to no needing to learn to get used to it, but the software store could be improved.

5 Likes

Hello and welcome!

Those are very valid criticisms of the Software Store, it has still many rough edges in some areas. Do you recall what was the error that appeared for that second issue you mention, and what command did you use to fix it? This can come in handy to other people coming in without experience with Linux.

I would recommend to run the Software Updated on every new fresh installation before attempting to download additional packages. This goes a long way in fixing small annoyances and issues.

1 Like

I don't remember the exact command to fix it, but what I remember is that the command was already written in the error message

So you basically just need to open the terminal, type "sudo" and then paste the command that the error message tells you to use and that fixes it

I think it was something about the software store not having permissions to install/uninstall packages, but I can't fully confirm it

In a few weeks I'm gonna reinstall Zorin again, so I can get rid of the Windows and Linux Mint partitions to have more storage in the laptop, so if that appears again, I'll copy-paste the command here and send a screenshot of the error message

1 Like

The gnome software store is a freaking mess, unfortunately. It has always been buggy and slow, and I don't understand why this is not improving. Manjaro's Pamac is a bliss compared to any software app I have tried.

2 Likes

I just reinstalled the system on the same laptop, following the same steps and doing everything the same and the error never showed up

I'm guessing they fixed it with an update :man_shrugging:

In the never version of Gnome Software Store all these issues have been addressed. The bad news is they won't get backported.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.