Folders in my backup are empty!

Right I've just had the thing happen that everybody is scared sh**less of!
After doing the upgrade I went into the external hard disk where the backup file is and transferred the contents only to find some of the folders empty!!
I can see all the folders, and many of them contain other folders but no files at all. Some folders are fine with everything where it should be.
There was a horrible sinking feeling and then a scrabble to try to find if I could recover anything. Shortly afterwards a number of expletives were heard resounding around the house, which were repeated a fairly regularly over the next few days!

The situation at this point:
The files that I have identified as empty so far include a large number of photo folders, the home/snap folder which contains all the Thunderbird and Brave stuff (and strangely in brave brouser/default there's no bookmarks folder to be seen! Though it would undoubtedly be empty anyway), and some other folders of files which are fortunately saved in a previous backup.
The backup program used was Back In Time.
The hard disk is a rather old WD Elements 750GB, but nothing else appears to be corrupted on it. And yes that was the only back up I did so I have only myself to blame.....
So far I've done a Testdisk deeper search from a usb launch and I was unable to access anything useful from previous versions on the partition. Of course as I didn't realise any of this stuff was missing I merrily overwrote the partition with the new Zorin 16.2, downloaded some programs like Brave and Thunderbird and even transferred the home folder so if, as I'm guessing you'll tell me, everything tends to get written to the same areas of the disk, then I'm probably pretty bunkered!
I did see listed as a separate partition what seemed to be the previous version but when trying to see inside it I got "no file found, filesystem may be damaged".

So now I'm wondering:
Is the disappeared data actually still there on the external hard disk, just not visible? (I get "file empty" when looking but you never know....)
Is there any chance that I can somehow extract the information from the external hard disk?
The external hard disk is formatted FAT32 and i read somewhere that it should be formatted NTFS for the Backintime to work properly. Is there anything related to that which could help?
I recently deleted a copy of my home folder from a thumb drive (which would contain the missing photos), can I use Testdisk to extract them?
Finally I found a folder with half a ton of .deb files that I can't open (computer/var/cache/apt/archives). I don't really know what they are but could anything be held in there?

A lot of questions for a sunday night I know, but I'm trying to squeeze this in between a pile of other urgent things I need to deal with.
Anyway any help with this would be very much appreciated as you can imagine!

PS reminder: Asus P5KVM, Zorin 16.2 core, fingers and brain becoming arthritic

Hi, I feel your pain. I had an argument at home over a year ago and wanted to look at another OS ... and wiped out my Zorin 15.3 (and no backup!). Ce la Vie!
I have never used Back In Time so can't assist - I misread your post and thought I read Time Shift - I made an error with this backing up to a WD Elements drive which is formatted to NTFS - Time Shift requires Ext4!
In terms of your USB, yes I would give Test Disk a try.
There is a pricey paid for solution but when I ran the demo on trying to recover a work colleagues data it picked up most things.
GetDataBack NTFS.

I'm defo going to try Get Data Back it looks pretty comprehensive. I think I've got a good chance with the photos on the USB at least.
I'll let you know how that goes when I get back from working away for a few days.
Working with fingers crossed for three days is going to get uncomfortable!
Thanks very much Swarfendor.

I hope you get sorted. I did try TestDisk when I wiped Zorin off in error when I should have been installing to the Hot Swap bay! D'OH!

Hello again,
so I tried Get Data Back and R-Studio which were useful but didn't discover any of the most important data unfortunately. I will try again in due time but running the deep scans is quite time consuming and I'm short of that (time) at the moment.
I decided to just get on with restoring my old home folder but I've run into a new problem.
When trying to restore backintime config I get: "Destination filesystem is formatted with FAT which doesn't support hard-links. Please use a native Linux filesystem".
I imagine I'll have the same when trying any kind of interaction with the external hard drive.
So question is: How can I reformat the drive so that this is resolved without losing the data?
Can I just copy and paste the backup folders to an Ext4 drive or partition somewhere and then point the BIT to that without damaging/corrupting them?
Or can I somehow reformat the drive the files are on while they are still on there!?

I would never reformat the drive while folders are there, that is a sure fire way of losing your data forever. Try the other option of copying to Ext4 partition.

Ok, many thanks Swarfendor.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.