Gdebi GTK Not Installing Any .Deb Files

Hello,
I installed gdebi for installing .deb files, also have set it as default for installing .deb files. The problem that I face is that when I click any .deb files it opens gdebi gtk, but when I click install it just exits the app and nothing else. Gdebi (terminal) edition works fine and installs the file.

I am using zorin os 15.3 lite

Any way to fix this issue?

Did you try a reinstall using Synaptic?

If I recall, there is no need for gdebi. The one time I did double-click on a .deb (way back when I hadn’t been indoctrinated by Aravisian and Swarfendor), Software Manager opened up and installed the application.

No, I haven’t. By the way the purpose of me choosing gdebi is that it installes any missing dependencies too :slight_smile:

I veered toward aptitude but I see your point. A nice comparison here: https://askubuntu.com/questions/309113/what-is-the-difference-between-dpkg-and-aptitude-apt-get

Reinstall didn’t fix that either, any other gui based tool that will also install any dependencies while installing a .deb file?

See: https://unix.stackexchange.com/questions/405520/gdebi-keeps-crashing-when-install-is-clicked#416002

Not exactly your situation but I think the solution may work for you.

pkexec gdebi-gtk launches gdebi-gtk as root and also installs any .deb file selected from within gdebi-gtk itself. Once authenticated it won’t ask you for the password when you click the install button though. Is there way to like launch gdebi-gtk as root in the file manager itself? When I used custom command to open .deb files (pkexec gdebi-gtk) in properties, it will only launch it as root. Any way to like make it open as root with the selected .deb file in the open directory itself?

Try https://www.ubuntu18.com/ubuntu-enable-root/

I have enabled root login what I want is this:

is there way to like launch gdebi-gtk as root in the file manager itself? When I used custom command to open .deb files (pkexec gdebi-gtk) in properties, it will only launch it as root. Any way to like make it open as root with the selected .deb file in the open directory itself?

I thought that is what that link suggested, no? The section halfway down that page, “login as root in Ubuntu desktop GUI” will have you on the desktop as root. Then, when you use Nautilus to launch an application it should launch as root? Maybe I’m missing something.

Umm, no what I wanted is that like when you select the option in thunar open terminal here and the terminal opens in the current directory itself, I want gdebi-gtk to open as root for the selected .deb file itself (it shoudl not open plain gdebi, but gdebi should open with the .deb file that I have selected)

Sorry, if I am making everything complicated by the way :sweat_smile:

Don’t apologize - you have an idea of what you want - I am just slow in understanding what it is.
By the way, something I found online that may help with your original question: http://forums.debian.net/viewtopic.php?t=48234

Moving on to the open-as-root option, I assume you already have gdebi set as the default for .deb files. The Right-Click->Properties->OpenWith tab setting?
With that default setting in place, I assume you mean a right-click option for Open as Root. I found this for Thunar: https://askubuntu.com/questions/198128/how-to-add-custom-action-to-open-folder-as-root-to-thunar and this for Nautilus: https://askubuntu.com/questions/703530/can-i-open-a-file-as-root-by-just-using-the-right-click-menu
Are these it?

1 Like

Thanks, launching thunar as root and opening the .deb file from within it fixed the isssue. For future readers here are the complete steps in a simplified way:

first launch thunar as root via pkexec thunar and enter your password when prompted.

Select the .deb file go to properties and select Gdebi Package Installer (even if you had changed it in normal thunar, you have to do it in the root one)

Open the .deb file (double-click on the file) and wait for gdebi-gtk to read the .deb file (the main gdebi-gtk window will be blurred out when that is happening)

Click on the install button and voila!

Note: Since thunar has already launched gdebi-gtk as root, it will not ask for your password again when you click the install button.

Again thank you very much @carmar for the help :smiley:

1 Like