Grub-efi-amd64-signed failed to install into /target/

Hello everyone,
I am sorry if I’m violating any forum rules. I am new to the Linux world and to the Zorin community. Very recently I have been trying to install Zorin on my old laptop and during installation, I am receiving the error that is written on the topic. I have wiped windows 10 and unfortunately, due to the error, there is no bootloader installed on my computer. I have observed that many users faced this problem and there are several solutions. Upon many trials, I have failed again and again. I would really appreciate your help if you have time. Thanks.
My laptop model is: Samsung NP-S3520
The error: grub-efi-amd64-signed failed to install into /target/
I have tried:
1- Skipping third-party applications and updates
2- Creating my own partitions that I have seen from the videos
3- Downloading the updates and third-party applications
4- Restarting

@SecretRiddle Hi and welcome to the Forum.
Couple of questions first to help us help you:

  1. Which flavour of Zorin are you trying to install, e.g. Core, Lite etc ?
  2. Have you confirmed the SHA256 checksum of the downloaded Zorin OS file is verified ? see this Methods of downloading Zorin OS

I have done a quick web search for the error posted in your title and found this, which may or may not help. Note Zorin 15.3 is based on Ubuntu 18.04, so fixes for that distro should be equally valid.

Hi zabadabadoo,
Thanks for your support.
The answers to your questions are:

  1. I am trying to install the Lite 32 bit version.
  2. I haven’t done that until now. After reading your message I followed the instructions and the program, quickhash, verified that both the iso file and the numbers on the website are the same.

The web page you have posted here, I already visited before. The instructions did not work for me. I received the very same error. The author on that web page also advising turning off the “secure boot”. I do not have such an option in my bios. Apart from that, I tried everything that he has written.

Do you have any further ideas? Thanks.

Do you have anything in BIOS called “UEFI”? If you do, switch that to legacy mode. My recommendations for partition sizes. But the problem is UEFI, so that is what needs to be changed in BIOS.


In addition to Carmars suggestion, while you are looking around in BIOS, ensure that Secure Boot is disabled.

When you Install Zorin and are creating your partition (The Gparted Screen) ensure that when you get to the screen that gives a Pop Up window that asks how to format the drive, (ext4) that you select (/) as your mount point.

Lastly, you said you are trying to install 32bit version but you are getting an AMD64 error. Have you tried installing Zorin 15 64bit?

1 Like

Hello carmar,
Switching to legacy mode worked for me. I don’t know how but I am happy right now. The installation process went fine and I did not see the error this time. For the moment I am using my Zorin laptop and replying through here. Many thanks.

Hi Aravisian,
Thanks for the help. Carmar’s suggestion helped my problem. I selected to erase the disk option, leaving the process to happen automatically. I read somewhere that ‘amd64’ had nothing to do with 64 bit systems and my computer only has 4GB of ram so I went with the 32 bit version. For now everything seems good. My computer is relieved and works faster than ever before. I really appreciate the answers.
Take good care!

Dunno where you read that- but that is incorrect.
Intel AMD has Everything to do with 64bit systems- They developed it.
AMD64 is x86-64 or x64.
An AMD64bit can run a 32 bit system.

1 Like