Grub menu still appears on Zorin 17

Lines 32 to 41.

Leave the EOF at 39 uncommented? Not 32 to 41?

All lines from 32 to 41 should be commented out. This includes the line 32 and 41 themselves.

Okay. Commented them. Rebooting to check.

Remember to save the file and sudo update-grub before rebooting...

Oops. I didn't save the grub config. Rebooting. Haha.

1 Like

No. It's not 10. It's actually counting to 30. And yes, the lines are comment in that os probe file

Did you run

sudo os-prober

in terminal?

Yes. I ran

sudo os-prober

Then

sudo update-grub

But still the timeout is the same. Not sure what's wrong.

What output did the above command give in terminal?

Nothing

Ok. I am quite stumped, here. Your system is behaving as if there is another OS installed along with Zorin OS. Yet, nothing (efibootmgr or os-prober) shows anything.
The style is set to hidden.

I will need to get some rest, but will try to research this in depth later.

@Aravisian Of course. Sure.

Thank you very very much for your help today. Hope I have not taken all your time. I'll revert all the changes so that if you have something I can redo.

1 Like

This is how the mountpoints are:

nvme0n1                   259:0    0 465.8G  0 disk 
├─nvme0n1p1               259:1    0  1000M  0 part 
├─nvme0n1p2               259:2    0   500M  0 part /boot/efi
└─nvme0n1p3               259:3    0 464.3G  0 part 
  ├─zorin-root            253:0    0   111G  0 lvm  /
  ├─zorin-home            253:1    0    25G  0 lvm  /home
  ├─zorin-volume--z       253:2    0 232.8G  0 lvm  /mnt/volume-z
  └─zorin-timeshift--backups
                          253:3    0  46.6G  0 lvm  

Just Zorin 17 only, no dualboot or anything

It's already disabled. My laptop has no cd/dvd support (no optical drive)

The "network stack" is already disabled - enabling this showed me options for network boot so I left is to disabled (not in the screenshots)

@337harvey, your opinion: Would this cause the OS to think another bootable medium is present?

@Aravisian @337harvey

This is the partition set up.

The 1G partition (ext4) I set it for /boot. The next one for EFI partition, and the remaining for LVM. Do you think that the first partition is causing the problem and is not actually being used - as the mount point is not mentioned?

Output from "df -h":

image

@337harvey

I've turned that 1g partition to unallocated space, then checked after a reboot. Still same.

Then I commented the lines in os-prober file as mentioned by @Aravisian, and updated the grub, then rebooted.

Sadly, still the same.

@337harvey No problem. Take your time :slight_smile:

No. I do not find any timeout settings related to boot in the BIOS.

Please let me know if you need any further information. Happy to provide.

And, a very Happy New Year @337harvey @Aravisian

No, there is nothing in the theme configuration file that can or will change the timeout.

I am very stumped by this, as well.

1 Like