Grub menu still appears on Zorin 17

LVM systems need not be encrypted.

One major advantage (there are others) is that you can easily expand your available storage by adding another partition even if the added partition is not adjacent.

I've been using it for years (with no encryption) and wouldn't want to go back to standard installs.

However, the user needs to learn some new concepts and management commands. That is enough to deter some people.

Don't want to hijack this post but i am having the same issue. I followed all the steps you guys suggest and still same result. Also per the grub default time out. It was set to 0 when i opened it. I do not have grub customizer installed or have i tried installing it.

I just checked on my copy of Zorin OS 17:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

However, I am dual booting with Zorin OS 16.3

I wonder if non-dual boot installs result in the new 0 default. This may need to be addressed, since a 0 second timeout can prevent users from accessing the Recovery Menu.

1 Like

This weekend i am going to install it on my test machine and see what happens. This version i am using is slightly tweaked (No grub edit) so i am still a bit doubtful about my results but i will give an update if this isn't solved.

1 Like

@xeroone Thanks

1 Like

I too have a similar issue. I am currently using Zorin OS 17 Pro. I have made all the modifications suggested in this thread multiple times. I do have grub customizer installed as it was my initial goto to make changes easily or to ensure that I wasn't messing anything up, however, the issue persists. Similar to Op i continue to get approximatley 30s timeout on grub to select Zorin OS which is only OS on machine. My machine is more quirky in this case though as it is a iMac 21". I know apple hardware can be finicky but I don't believe that is the culprit in this case as well as other people similar experience.

Grub Customizer saves configuration files outside of the normal paces, and I am not even sure where they all are. It's been years and I have yet to untangle it.
While I can understand that from your point of view, you would not believe that Grub Customizer is involved (and perhaps it isn't. Perhaps...), just having it throws a very large and unpredictable wrench into the works and makes any sort of troubleshooting much harder.

Our hands are tied in checking the normal things, since there can and will be other configurations saved elsewhere.

Any fix for this issue?