Gtk python errors after update

I performed the latest kernel update offered by software, which included several libraries and the new kernel version (i don't recall of the top of my head which version exactly). After this update i was working in the os for some time, then finally shutdown for the day. Yesterday i booted into zorin to work on my final project for school, everything i normally used started correctly (slack, zoom, Firefox and vscode). When i attempted to open the terminal, nothing happened. So i opened xterm and tried gnome_terminal. Gave an error that a python library wasn't installed. Under /usr/lib/ the library existed for 3.8. I have 3.9 installed for my programming. I even installed the _gi library (to create a system tray icon for a program) , version 3 for python 3. It was two of these files it couldn't see. So i copied them with 3.9 instead of 3.8 in the title and it stopped erroring and gave me the terminal.

I have update-alternatives set with both versions of python 3. This has never previously come up since the system would use the 3.8 python, while iuses 3.9. Then i tried to open another gnome application, gedit, but same issue, different library.
Then zorin appearance, same problem. How does a kernel update break python dependencies? This has also effected my audio. The A2DP codex doesn't work. Had i not had pipewire running, able to choose a different codec, i wouldn't have sound. This won't do.

I restored from my tineshift, but it didn't fix anything... only made things worse. Even kdeconnect isn't working, but most other qt apps are.

I'm at a loss. I'll be rolling back to a previous kernel... but how... why put out an update that completely destroys gnome? Is there any other way to fix this? @Azorin or @zorink may be able to resolve this... but I'm curious if any others are having this issue? Gnome will load, but a good portion of the applications will not start.

I can clearly see how the kernel would depend on the package version that comes with the OS as it is that package that it looks for. Since you have a later version installed, it sees a Blank Field of Emptiness instead of python 3.8.
Python 3.8 is there, but the view is blocked by Python 3.9 which says, "This is not the python you are looking for."
I can see no solution to this that isn't tricky.


I wonder if update-altetnatives,, bring a part of the kernel, was damaged or changed during the update. It was working fine before, where the system recognized and used 3.8 while i called and used 3.9. It would take further testing or using the kernel version of python to code (which i won't do because of the extra packages i use to code, so conflicts aren't created or dependencies overwritten). I don't have the time or want to dive further into this.

1 Like

Update: i reinstalled using the latest pro download (kernel 5.11.0-38). After installing all of my applications i restored my home folder... big mistake. Something in that configuration has things really messed up. So i reinstalled again, transferred my .bashrc, .gitconfig and a few other innocuous items (downloads, pictures and documents). I used Aravisian's guide to quickly reinstall applications (worked like a charm) except for python 3.9. I had to use sunspot to remove all traces and reinstall it.

My gnome is all but configured with Aravisian's themes and my files... the way it used to be. Next is to configure KDE (yes I'm still running Plasma). I've already done one timeshift backup.

The kernel did update to 4.1 during installation, but since update alternatives wasn't configured, didn't break anything. I reconfigured update alternatives and was sure to leave python 3.8 in control. 3.9 is recognized but only accessed from the alias i created. This way the system knows about both but uses the correct one.

I'll give another update when everything is completely configured.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.