HDMI output not working [Zorin OS 16 PRO]

Hi everyone,

I am new to the Zorin OS community and I am seeking some help with a display issue. I have been trying to connect my laptop to an external monitor via HDMI, but I have not been successful. I have already tried changing my drivers on the settings, but it did not solve the problem.

The only solution that worked was using a USB-C to HDMI hub, but the image quality is not great due to screen tearing. I am a Linux newbie, so I apologize for any mistakes I may have made.

My laptop is a Dell G15 with an i5 12500h and RTX 3050 graphics card. I am aware that Nvidia graphics cards do not always work well with Linux, but unfortunately I don't have many options in this case.

If anyone has any tips or suggestions on how I can fix this issue, I would greatly appreciate it. Thank you in advance!

Gday @muryllo , Welcome to the community!
Zorin has a great Nvidia comparability range.
AMD/intel can be tricky.
In saying that can i ask you to plug-in the external monitor/ via usbc cable.
Open " Software Updater ", once it has loaded, click " Setting " at the bottom, goto " Additional Drivers " hopefully you see the drivers recommended in the list, if so select the driver & process with the Update, resart pc & try.

Q: Is this dual boot?

Note: some cheap usb cable may have trouble over distance.


Also some cables are directional. You might try flipping the cable around.
RTX 3050 on Zorin OS should be stably supported.
I have a 3060 which is Rockin'.

1 Like

"Basically it seems that by default it only allows auto setup of one extra screen. I had to go into the Nvidia control panel > display > Setup multiple displays. Plugged in both, one was blank, then went and ticked them both on within the area that says "select the displays that you want to use" then hit save and then bang, both came on."

"I had the same model and the same issue. The issue disappeared after installing nvidia-driver-470."


Thank you for your response and for taking the time to research a possible solution for my display issue. Unfortunately, the solution you provided did not work for me.

I appreciate the effort you put into helping and search for these links, but I wanted to let you know that I do not have the Nvidia control panel on my Linux, and the Nvidia X Server Settings only displays a blank screen (?) which is likely due to a bug I guess.

If you have any other suggestions or ideas on how to fix this issue, I would be happy to try them out. Thank you again.

Thank you for your response and for welcoming me to the community. I really appreciate your help.

Unfortunately, I have already tried the steps you have mentioned, including changing the recommended driver in "Additional Drivers", but I still do not have any image output through the HDMI port. The only way I can get any image on my external monitor is through the USB-C hub, but it limits my refresh rate and causes screen tearing.

To answer your question, I am not currently using a dual boot system. However, it is something I am considering for the future just for gaming.

I am glad to hear that your RTX 3060 is working well with Zorin OS.

I have tried using the same HDMI cable in both directions, but unfortunately, it did not work. Before switching to Zorin OS, I was using the same HDMI cable on my Windows 10 system for over a thousand hours without any issues, so I believe the problem is likely related to the Nvidia driver.

I agree based on this:

This means driver.
Can you please run in terminal:

sudo ubuntu-drivers install

Add the Ubuntu XSwat team driver repository:

sudo add-apt-repository ppa:ubuntu-x-swat/updates

Update and upgrade

sudo apt update && sudo apt dist-upgrade

Reboot and test.
If no luck in the Additional Drivers tab please try the bottom option -Nouveau.
Then try the 470 and 510 proprietary drivers (not server) each.

Hey @Ocka, @Aravisian and @Mr_Magoo.

I wanted to provide an update on my HDMI output issue and let you know that I found a solution. It turned out that the Secure Boot on my laptop that was preventing the Nvidia drivers from being loading correctly, and disabling it resolved the problem.

Also not ironically, I was actually having trouble accessing my BIOS because Zorin OS was booting up too quickly. However, I was able to access the BIOS by using this command in the terminal:

systemctl reboot --firmware-setup

If anyone else is experiencing a similar issue, I would recommend checking your Secure Boot settings to see if that might be the problem. Thanks again for all your help!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.