Help, my Desktop isn't loading after logging in,,,

Currently using Zorin OS 16.2 Lite right now.

My Desktop on Zorin OS 16.2 Lite isn't loading the wallpaper and the desktop apps I've added after i login my user, The panel loads perfectly so it gives me access to chrome and stuff but Its been stuck like this since yesterday.

I don't know if this is some sort of failure with the system or the Driver as I tried going into recovery mode to update the system or clean the files and rebooting but it doesn't work. Maybe it was the packages I've installed in the terminal but I'm not sure. Im sort of a Noobie in Linux as I started using it this March. I feel like reinstalling Zorin OS again if i couldnt fix it.

I dont know if this will help you guys on solving it but here^^^

Maybe try

sudo apt install zorin-os-desktop --reinstall

Hey, Turtle11.

I tried using “sudo apt install zorin-os-desktop --reinstall” but it kinda doesn’t fix the problem :p.

Any more you can think of?

What does the error say?

Oh I am so sorry, I didn't read you were using lite, it's

sudo apt install --reinstall zorin-os-lite-desktop

Err, I didn't really get any sort of error in the terminal as It successfully did the code you did without any errors occuring so I restarted the system expecting the desktop to be back on but It didn't (<- was that a bad idea restarting the system?)
but uhh i got a new error in the logs
Screenshot from 2023-04-01 15-55-41

Oh lol, Its okay. just wait while i use the command in the terminal, i'll tell you the results afterwards,,,

Alright, I'm done using the command you told me. do I restart the system now or nah?

I guess.

Hey, just restarted the system a minute or two ago and it still doesnt fix the desktop ;<

if you still have any solutions/commands you can use, you can type it here and i'll try it. if you ran out, its all cool : )

The only thing I can assume caused this is a broken package in the install, not the DE. Somehow.

Maybe @Aravisian or @staff or someone else can help.

1 Like

At any point, have you removed ~/.cache and tried resetting your configs to default?

mv ~/.config /.config-bk


I can't understand why this post has been marked as "Solution".

1 Like

Me niether!

@Hey84O8 We cannot understand why Turtle11 post #11 has been marked as "Solution", so I will unmark it.
If your problem is fixed, please say how. You can always mark "Solution" again.

Sorry about that guys, , , I kind of didn't wanna fix the problem anymore so I just pracically gave up on fixing it and marked Turtle11's reply as solution without it fixing the problem and backed up my files on MEGA and reinstalled zorin afterwards... :PP

I would probably just delete the topic now if i can but idk ¯_(ツ)_/¯

Is it the problem the same after re-installing Zorin?

If re-installation fixed it, then that can be marked as the "Solution".

You can't. It would throw an error at you if you attempt to delete a thread with replies. I tried doing the same thing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.