How can I make the clock stay longer after monitor Suspend?

It's a nice feature but too fast to read.

I may not be understanding your question... But it appears to be that a clock displays on your screen when you suspend but it quickly disappears.
It disappears because the Computer is going into Suspend - and is unable to display the clock or anything else.
Since that is what Suspend is, you cannot make the clock last longer without slowing down the action of suspending the computer. It defeats the purpose of Suspend. But, as another option, you can not suspend, and instead, LockScreen, allowing the clock to run as the screensaver on the lockscreen, with the computer not suspended.

No. When you RETURN from Suspend (actually, Video suspend now that I think about it), a large clock briefly displays in the middle of the screen. Too fast for me to really read unless I am concentrating like a hawk.

I have never seen this really... But I use Zorin OS Lite, not Core, so maybe I have not been exposed to it.
It really just sounds like you have got a Quick Computer. The clock is an interim wait...

I use a HUD Clock on my screen that is omnipresent with Conky. If you are looking for a Clock you can glance at and control at will - we can set that up.

Ha, all of my computers are old biz PCs that I buy for $80 and add a $20 SSD to. The one I'm talking about is a dual core Lenovo (now I always look for quad Dells). Win10 runs very well on these, BTW, but I can't upgrade to Win11 which POed me. Zorin is working great.

Output of:

sudo dmesg | grep MHz

What's that?

It is a terminal command that relays to you your CPU clock speed.

I know my CPU clock speed (slow). I want to make the clock that appears when you resume from monitor blanking last long enuf for me to read. Large digital clock in the middle of the screen. Nice feature, otherwise.

Doesn't anyone else see this? It couldn't be my monitor doing it. It doesn't know the time.

I realize I created confusion by mentioning two different kinds of clocks.
I was trying to determine if your CPU was fast enough to run init, causing your Display Clock to only briefly appear prior to loading the desktop - as this seems to be the likely case to me.

if you go to settings > energy > automatically suspend, you can set those to never, then lock manually to get that lockscreen with the clock (above power menu on bottom right by default)

I finally realized it was just the lock-screen flashing. Oops.