How do I get past this?

I was trying to update Zorin 16.3 Pro OS. I followed the Zorin website instructions to copy the files to a usb driver but I couldn't see it in the list of bootable drives in BIOS. I have obviously done something to the BIOS because now it won't go any further than the screen in the pic.
I really don't know what to do next.
Phil Jackson

Are you dual-booting ZorinOS and Windows, or only have ZorinOS Pro on that machine?

Was that screenshot taken with the USB stick inserted?

Thanks for your reply. The machine has been running only Zorin, very successfully for about 2 years. It doesn't make any difference whether the USB stick is inserted or not. I've also tried it with a bootable DVD inserted. It reads the DVD, then nothing.

Maybe your USB stick/driver died? Or did you tried it with another computer? Happened to me before. Hope you solve it soon.

Can you please post that link here? I am not sure what you are referring to.
Upgrading Zorin OS 16.2 to Zorin OS 16.3 does not require a USB stick or copying files.

If you force a reboot using the Power button are you always getting stuck at that Asus splash screen?

If so, enter your BIOS. See which boot device options are listed and what is their priority order? Post a photo of that here.

Are you saying you followed Zorin instructions to create a bootable ZorinOS USB stick using Balena Etcher?

Have you tried using another tool e.g. Unetbootin or Rufus etc?
(Balena has a history of problems reported on the forum, including corrupting USB sticks)
Also, please, please take time to confirm the SHA256 checksum of the downloaded .iso file, before attempting to create your bootable ZorinOS USB with it.

Thanks for your reply. I have tried the disk on another computer and it seems OK.

Thanks for your reply. When I upgraded to Zorin OS 16.3 I didn't get the Pro version. The instruction in the email told me to use my original key to upgrade to Pro. I followed Zorin instructions to create a bootable ZorinOS USB stick using Balena Etcher. It worked fine until I tried to get the bios to use the USB stick to boot. I think I've done something to inhibit the boot-up, but I don't know what. I'm a gonk when it comes to anything technical, so I don't know how to get past the screen above to correct anything. I don't think there is anything wrong with the USB stick as I've tried it on my laptop.

I can't get past this screen. No matter what I try I can't get into the bios. It always sticks at the Asus splash screen.

Here is the instruction from the email:
If you’ve already purchased Zorin OS 16 Pro, you can download a new copy of Zorin OS 16.3 Pro or Pro Lite from the download link in your original purchase email. If you lost access to this email, you can resend it here.

Before this began, did you start a bios update? Did it freeze or get interrupted in any way?

Are you saying "Please press DEL or F2 to enter UEFI BIOS setting" from the Asus splash screen has no effect?

There may be something here that helps you: [Notebook] Troubleshooting - How to fix frozen ASUS / ROG logo screen | Official Support | ASUS

Another thing that would be easy to try is this: hard drive - ASUS laptop stuck in splash screen loop. Can't access BIOS with HDD installed - Super User

Scroll down to the Answer marked "-1" regarding removal of battery and charger to cause shutdown.

I am sorry Phil, I still do not understand what you mean.
Upgrading from Zorin OS Pro 16.2 to 16.3 is a Point Release. It will not change your edition, nor will it change you from Pro, Core, Lite or Pro Lite.
There is no need to use a USB Stick or Disk.

Were you upgrading from Zorin OS 15 to Zorin OS 16.3?

I agree that it is not likely the USB Stick because the situation occurs when no USB stick is insterted.

Do you recall ever entering your BIOS Settings to change Boot Order?

The more details that you can provide that can clarify the confusion above, the better we can try to be helpful. It can be helpful to know what version of Zorin OS you were running prior to upgrading.

Zorin OS, Windows OS or even Mac OS - All these operating systems are independent of the Motherboard Operating System which we commonly call BIOS. Even if the Zorin OS system was corrupted or Damaged, you should be able to access your BIOS Settings from boot. If you cannot, there may be a fault with your motherboard. Believing you are not a technical person may lead you to believe you are at fault when it was a motherboard fault all along.

Hi "Please press DEL or F2 to enter UEFI BIOS setting" has no effect.
Did I mention that the computer is a desktop, not a laptop?

Hi Aravisian. Thanks for your reply.
I upgraded from Zorin Pro 16.2 to 16.3 but I didn't get the "pro" version. There was advice in the email to download a new cop of "16.3 Pro" by following a link, which I did, which entailed using "Balena Etcher" to create a bootable USB stick. The USB stick did not boot up the computer, so I entered the bios to change the boot up order, but I couldn't find the USB stick in the list. I must have altered something to do with the boot up order because now, it gets to the above screen and goes no further.
I tried removing the button battery and replacing it and I have flashed the bios using the jumper. I'm using the words here, but I don't really understand what I'm doing (I know, I'm the worst kind of patient!). I'm guessing that everything I've done has made the situation worse, however, apart from having my hands on it, I don't thing the is anything physically wrong or damaged.

I do not believe it is the USB stick or the boot order. You may have changed the boot order, but you would still be able to access the BIOS Settings to change it back even if you change the boot order.

If you tried replacing the CMOS battery - I would definitely check there. Good thing it is a desktop - much easier to open up and work on. Make sure the battery is charged and good and seated properly and in the proper position (+ to + and - to -).

The jumper, too, I would check.:

These two above are the most likely culprits of your no-boot condition and either of them can lead to the motherboard not initializing.
I am leaning toward the Jumper, myself.

Thanks for the info. I've checked the jumper. Took it off and put it back, making sure it was seated properly. The battery looks OK and seated properly. No difference. Other than replacing it with a new one, how do I check the charge in the battery ?

If you have a voltmeter...

I haven't got a voltmeter, so I'll buy a replacement battery. I'll let you guys know when I've done that. Thanks in the meantime.

I've now replaced the battery with a new one. Still no difference.