How do I get rid of the tiny little keyboard icon in the taskbar that appears when it detects a touchscreen?

Like, I very clearly have On Screen Keyboard switched Off in Universal Access, yet it appears in my bottomright tasktray anyway. The real problem comes from the fact that if I click on it, it’s impossible to dismiss. You can’t click on the [v] button to retract they keyboard, and you can’t rightclick on it to find any options (it’ll just summon the undismissable keyboard again).

I have a touchscreen which is why I suspect it’s even there by default without my consent but it’s unbelievably buggy.

I assume you are using Zorin 15 Core or Ultimate, in which case:
Gnome. I will stop myself there.

There is, at least, a Gnome Extension that Blocks the onscreen keyboard on a touchscreen:

Found it: it’s cleverly hidden in Tweaks > Extensions > “Zorin Screen keyboard button” at the very bottom

This is useful knowledge in case someone else runs into this issue of where to find the real toggle On-screen keyboard button on touchscreens.

1 Like