How do I run UAD GUI file?

I'm trying to install Universal Android Debloater on my 32-bit Zorin 15.3 Lite OS. I've followed the instructions located here, and now I have the UAD GUI tar.gz file on my desktop. I think I'm supposed to extract it next, which places a single file called uad_gui-linux on my desktop. When I try to open this file, the "Open With" box pops up and I'm supposed to choose which application to use to open this GUI.

I've looked at numerous videos and walkthroughs online, and it seems extremely easy for others because they just say "install it" and they immediately have the GUI open. Which application should I select? I think it's supposed to simply just open the GUI, but it doesn't seem to be doing that for me. Does anyone have any tips?

Try running it through terminal
Open a terminal in your file location.
and run ./uad_gui-linux
and see if throws an error

You may need to grant it executable permissions. Easier is from the terminal:

chmod u+x ~/Desktop/uad_gui-linux

But you can also right-click on it, go to properties and then permissions.

Here's the error that came up when I tried that.

bash: ./uad_gui-linux: cannot execute binary file: Exec format error

Access is "Read & Write", and I've checked the box that says "Allow this file to run as a program".

Since it doesn't have a file extension, does that mean it's not an executable file? Or could it maybe be incompatible due to my 32-bit OS?

It's possible this won't run on 32-bit OS, yeah. But that's something you should check with the developers of that program, typically they would provide a 32-bit version separately if there is one available.

Thanks. Yeah, I posted on the project pages, and they confirmed that the software requires a 64-bit system. So that explains it.

Thanks for the help!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.