How I can install orage calendar in zoirn lite?

I tried to install orage calendar with follow README.md file instructions for installing, but I can't do that.I get nothing when type make install, Have any one ever tried install it in zorin lite?

You can get the Installer .deb file here:
http://launchpadlibrarian.net/453836677/orage_4.12.1-7_amd64.deb

error message: unable to install "oraage globaltime": the following packages have unmet dependencies

I had to double check this since That package is in the Focal Repositories.
The dependency is that the XFCE4 panel be version 4.14 which is what is used in Focal and Xubuntu 20.04.
But Zorin OS 16 uses xfce4-panel version 4.16

https://docs.xfce.org/apps/orage/start
in that site there is new version, but not .deb, and not easy in its installing, i tried but i can't

Eh, I am not sure. As I understood it, Orage has not had an active maintainer for a while...
So, I looked it up. This is what I found:
https://forum.xfce.org/viewtopic.php?id=14898

See post number 5.

I will look into this further, later.

1 Like


I don't know may be ,when i see that in there site , i thought that there is new version stable

1 Like

Ah, that is new...
I downloaded the tar.bz2 and extracted it.

Then opened a terminal within the extracted directory and ran the install commands.
It complained nonstop for references of files that do not exist or are currently depricated.
So, I made several changes to main.c and globaltime.c and got it installed. I uploaded the changed files here:

Download and extract the tar.gz
Open a terminal within the directory and run

./configure

make

sudo make install

and it should install without problems...

1 Like

image
I get that when I execute make

How did you get that error and I did not... Hmmm...
I do other dev stuff, so it may be that I have things installed that you do not.
Try

sudo apt install xfce4-dev-tools libxfce4util-dev

Then run make, again...

still get errors , I think may I need to install depended package as that included in the readme file:
image

Zorin comes with those as they are necessary for the O.S.

I also installed Orage without any more issues after doing the above - so I am not sure why yours is different.
Let me take a deeper look at it later when I have more time.

1 Like

I tried that:
sudo apt-get install build-essential libgtk-3-dev
it is working good now.
Thank u very much