How to auto mount 2nd internal HDD and activate WIFI dongle at start up

Before installing Zorin 16, I installed and used Linux Mint for a month or so in my old HDD. After i got a new SSD, I installed Zorin and have been my daily driver since.
However, I started to notice that Zorin doesn't mount the HDD drive automatically on start up but it does on my external HDD. As i needed more space for work, I googled on how to uninstall Mint and most searches suggested to just delete and reformat the HDD partition using Disks. I did that and got more spaces and started to move my work documents to the HDD. Its been 4 days now, and I am wondering if there is a way for Zorin to auto mount the drive at start up so i can access the files faster rather than starting Disk every start up to mount the drive.
I am still new to Linux, and thus the reason also moving to Zorin from Mint, for the easy installing Windows apps without tweaking or workaround that I had to do.

Ah small problem as well but if there's a fix would great, wifi dongle never seem to automatically active. I tried using the terminal command, forgot what it was, that to see if the system detect the device, and it did just not active. As I am new and can't remember the commands and tired of using phone to google every day, I usually just unplug and plug back to make the wifi automatically on and connect. So here my question, is there an easy way to set this so i don't need to unplug and plug the dongle every time I start up as well?

Maybe it's my tired mind, but can you please clarify: Are you looking to automount an external hard drive at boot?
Really, it should do so automatically.
Easiest to post a Full Guide:

For the Wifi Dongle, could you please start a separate thread on that as it is a separate issue. This helps other users find solutions to similar problems.

Sorry for not being clear.

I want to auto mount the internal HDD on startup.
I mentioned the external one, since it does auto mount on start up somehow but the internal HDD have to be mounted from Disks after every shutdown (restart will still mount the internal HDD if it was mounted before).

I tried mounting the internal HDD from Files-> other location. but the HDD is not detected until I mount it from Disks.

I'll try the guide above tomorrow.

In Disks utility, click the :gear: icon, then click EDIT MOUNT OPTIONS. Put check on these.

(1) Mount At Startup

(2) Show In User Interface

No such option in my Disks. the options i have are Format, Create Disk image, Restore Disk image, benchmark Disk, Smart Data, Drive Settings, Standby Now. I checked under settings, it only give time to standby, AAM and write cache which are all off atm.

Tried the post, it does work though not for the add username, so i skipped the username and straight adding in fstab.

Now Files detected the internal HDD and mounted it. Although the shortcut link i made before have to be remade again for ease of access to each folder in the HDD.

Thank you!