Zorin Forum

How to change the high-lite background color

When I want to copy text on the board I can't see what I am coping due to the fact I use a dark theme background on the board (and every where else) and the high-lite back ground color is also black .... how can I change this color to something else .... thanks

1 Like

Hope this helps

1 Like

No luck here .... I tried 2 different colors and restarted my machine 3 times .... still the same black on black .....

By the way I'm on Cinnamon DE if that makes a difference or not ....

You properly need to edit the gtk.css file of the theme you use directly.

1 Like

OK ..... that sounds logical .... let me check that out .... I'm using multi components of this theme so I'll have to find out which item effects that aspect .... by changing out each one and see which one is the culprit .... thanks

OK thanks for all the help folks but after looking at all the css files in the desktop theme folder I'll just drop it as my browser and other dark themed programs are not effected by this problem .... and I wasn't in Zorin until a few days ago it's no big deal ...

I appreciate everyone's help ....

Save the following in ~/.config/gtk-3.0/gtk.css

.view:hover, iconview:hover, .view:hover:focus, iconview:hover:focus, .view text:hover, iconview text:hover, textview text:hover, iconview text:hover:focus, textview text:hover:focus, flowbox flowboxchild:hover, row:hover, .view:selected, iconview:selected, .view:selected:focus, iconview:selected:focus, .view text:selected, iconview text:selected, textview text:selected, iconview text:selected:focus, textview text:selected:focus, .view text selection:focus, iconview text selection:focus, .view text selection, iconview text selection, textview text selection:focus, textview text selection, flowbox flowboxchild:selected, entry selection, entry selection:focus, row:selected {
     background-color: rgba(0, 170, 255, 0.5);
}

Change the rgba value to anything you desire. That is a Blue Color I have put there.
Log out and in to see the change.

1 Like

I guess I did something wrong as nothing changed ..... see the [/quote] is still black ....

Did you kill the browser and relaunch it?

1 Like

I shut off my laptop and restarted it ..... should I have just shut down my browser?????

Well, you could have... but rebooting is just as good.

Which browser are you using and how did you install it? That gtk.css file is located in /home/$USER/.config/gtk-3.0, right?

1 Like

I use Vivaldi

And Azenis2021... I updated this yesterday:

Please run

sudo apt update && sudo apt upgrade

Your Vivaldi is using default colors instead of System colors.

  • Paste vivaldi://experiments in a new tab in Vivaldi.
  • Check the box to "Allow for using css modifications."
  • Open Settings > appearance and check the box to Use Native Windows.
  • Go to themes and select Issuna or another that you prefer...

Download this file and then Extract it to your ~/.themes directory:

  • In Vivaldi Settings > Appearance "Custom UI Modifications", click "Select Folder" and navigate to your freshly extracted file: ~/.themes/vivaldi-azenis-theme

It should look like "/home/FROGs$USER/.themes/vivaldi-azenis-theme"

Now close Vivaldi and then relaunch it.

Navigate to ~/.config/gtk-3.0/gtk.css and comment out what is in the gtk.css (using the /*commented text goes here*/ tags) or remove it entirely.

1 Like

Sorry but I can't find "Custom UI Modifications in my Appearance setttings .... I have a Menu Customization but no Select Folder option .....

It seems, after enabling

  • Paste vivaldi://experiments in a new tab in Vivaldi.
  • Check the box to "Allow for using css modifications."

Close and relaunch Vivaldi to make the option appear.

1 Like

It didn't work still has black background when I try to copy and past any text on the posts ..... here is what I ended up with .....

Going to try and log out and back in ....

Interesting when I click on the Themes Setting in Systems Settings it doesn't open all the others work though .... and still no go with the copy and paste ..... I can copy and past I just can't see what I'm coping .....

OK I went back to the

And deleted what we added .... now my Theme Setting is back ....

Did you run

sudo apt update && sudo apt upgrade

?

1 Like

The first time yes but I'll do it again ....

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo apt update && sudo apt upgrade
[sudo] password for mike:
Hit:1 Index of /deb/nordvpn/debian/ stable InRelease
Ign:2 https://repo.vivaldi.com/stable/deb stable InRelease
Hit:3 Index of /stable/ focal InRelease
Hit:4 https://repo.vivaldi.com/stable/deb stable Release
Hit:6 Index of /patches/ focal InRelease
Hit:7 Index of /ubuntu focal InRelease
Hit:8 Index of /apps/ focal InRelease
Hit:9 Index of /aravisian/gtk-theming/ubuntu focal InRelease
Hit:10 Index of /drivers/ focal InRelease
Hit:11 Index of /ubuntu focal-updates InRelease
Hit:12 Download - Zorin OS focal InRelease
Hit:13 Index of /ubuntu focal-backports InRelease
Hit:14 Index of /aravisian/iconsets/ubuntu focal InRelease
Hit:15 Index of /ubuntu focal-security InRelease
Ign:16 Index of /mark-pcnetspec/conky-manager-pm9/ubuntu focal InRelease
Hit:17 Index of /qbittorrent-team/qbittorrent-stable/ubuntu focal InRelease
Hit:18 Index of /qbittorrent-team/qbittorrent-unstable/ubuntu focal InRelease
Hit:19 Index of /tomtomtom/conky-manager/ubuntu focal InRelease
Hit:20 Index of /zorinos/apps/ubuntu focal InRelease
Hit:21 Index of /zorinos/drivers/ubuntu focal InRelease
Hit:22 Index of /zorinos/patches/ubuntu focal InRelease
Hit:23 Index of /zorinos/stable/ubuntu focal InRelease
Err:24 Index of /mark-pcnetspec/conky-manager-pm9/ubuntu focal Release
404 Not Found [IP: 91.189.95.85 80]
Reading package lists... Done
E: The repository 'Index of /mark-pcnetspec/conky-manager-pm9/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
mike@mike-ROG-Strix-G731GT-G731GT:~$