How To Install Nemo On Zorin Lite

Playing around with Zorin Lite again ..... trying to get Nemo to replace Thunar tried what was suggested on Ubuntu but no luck ..... tried to use the settings panel but again nothing ....

Nemo is supposedly downloaded but my batting average these last few days is zilch .... 0 ..... nothing ..... :sob:

I'm on Lite now ..... got lots of questions but don't want to put them all in one thread ......

sudo apt install nemo

xdg-mime default nemo.desktop inode/directory application/x-gnome-saved-search

gsettings set org.nemo.desktop show-desktop-icons true

From the app menu, open Default Applications > Utilities tab > File manager
Click the arrow for the drop down menu. If Nemo is not suggested, select "Other" and enter in nemo "%s"

To get the Nemo Right Click open in terminal:

gsettings set org.cinnamon.desktop.default-applications.terminal exec 'xfce4-terminal'

1 Like

Thanks be back as I'm trying to figure out how to get my screen to split left to right .......

I fixed it ..... a setting in the Settings Manager .....

Well here we go again ..... I got broken packages ....... tried to delete the copy of Nemo on lite a few days ago using .... sudo apt remove --purge nemo ...... and now when I try to install I get this .......

No rush gonna take a break and eat lunch ..... :weary: :confounded: :scream:

You installed the Mint Dev Repo, didn't you?

And you forgot to Remove it after using it for retrieving Nemo 5?

To be quite honest I have no Idea ......

Let's check:

sudo apt update


ls /etc/apt/sources.list.d/

1 Like

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo apt update
[sudo] password for mike:
Hit:1 stable InRelease
Hit:2 Steam for Linux - launcher stable InRelease
Hit:3 Index of /deb/nordvpn/debian/ stable InRelease
Ign:4 Index of /stable/deb/ stable InRelease
Hit:5 Index of /stable/deb/ stable Release
Hit:6 Index of /stable/ focal InRelease
Hit:8 bionic InRelease
Get:9 Index of /ubuntu focal-security InRelease [114 kB]
Hit:10 Index of /patches/ focal InRelease
Hit:11 Index of /apps/ focal InRelease
Hit:12 focal InRelease
Hit:13 Index of /ubuntu focal InRelease
Hit:14 Index of /drivers/ focal InRelease
Hit:15 Index of /apandada1/brightness-controller/ubuntu focal InRelease
Hit:16 Download - Zorin OS focal InRelease
Get:17 focal-security InRelease [114 kB]
Hit:18 Index of /aravisian/gtk-theming/ubuntu focal InRelease
Get:19 Index of /ubuntu focal-security/universe amd64 DEP-11 Metadata [96.4 kB]
Get:20 focal-updates InRelease [114 kB]
Hit:21 Index of /aravisian/iconsets/ubuntu focal InRelease
Get:22 Index of /ubuntu focal-security/multiverse amd64 DEP-11 Metadata [940 B]
Get:23 Index of /ubuntu focal-security/main amd64 DEP-11 Metadata [59.9 kB]
Get:24 focal-backports InRelease [108 kB]
Hit:25 Index of /camel-neeraj/sysmontask/ubuntu focal InRelease
Get:26 focal-security/main amd64 DEP-11 Metadata [59.9 kB]
Get:27 focal-security/universe amd64 DEP-11 Metadata [96.4 kB]
Get:28 focal-security/multiverse amd64 DEP-11 Metadata [940 B]
Get:29 focal-updates/universe amd64 DEP-11 Metadata [410 kB]
Get:30 focal-updates/multiverse amd64 DEP-11 Metadata [944 B]
Get:31 focal-updates/main amd64 DEP-11 Metadata [275 kB]
Get:32 focal-backports/universe amd64 DEP-11 Metadata [30.5 kB]
Hit:33 Index of /exmplayer-dev/exmplayer-qt5/ubuntu focal InRelease
Get:34 focal-backports/main amd64 DEP-11 Metadata [7,960 B]
Hit:35 Index of /gerardpuig/ppa/ubuntu focal InRelease
Hit:36 Index of /mati75/gimp30/ubuntu focal InRelease
Hit:37 Index of /rvm/smplayer/ubuntu focal InRelease
Hit:38 Index of /tuxinvader/lts-mainline/ubuntu focal InRelease
Hit:39 Index of /ubuntuhandbook1/apps/ubuntu focal InRelease
Hit:40 Index of /zorinos/apps/ubuntu focal InRelease
Hit:41 Index of /zorinos/drivers/ubuntu focal InRelease
Hit:42 Index of /zorinos/patches/ubuntu focal InRelease
Get:43 Index of /zorinos/stable/ubuntu focal InRelease [18.1 kB]
Fetched 1,507 kB in 11s (131 kB/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done
5 packages can be upgraded. Run 'apt list --upgradable' to see them.
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository ' stable InRelease' doesn't support architecture 'i386'

Or this .......

mike@mike-ROG-Strix-G731GT-G731GT:~$ ls /etc/apt/sources.list.d/
apandada1-ubuntu-brightness-controller-focal.list rvm-ubuntu-smplayer-focal.list
aravisian-ubuntu-gtk-theming-focal.list steam-beta.list
aravisian-ubuntu-iconsets-focal.list steam.list.dpkg-bak
brave-browser-release.list steam-stable.list
camel-neeraj-ubuntu-sysmontask-focal.list tuxinvader-ubuntu-lts-mainline-focal.list
damien-moore-ubuntu-ppa-focal.list ubuntuhandbook1-ubuntu-apps-focal.list
exmplayer-dev-ubuntu-exmplayer-qt5-focal.list vivaldi.list
freedownloadmanager.list zorin.list
gerardpuig-ubuntu-ppa-focal.list zorinos-ubuntu-apps-focal.list
home:ungoogled_chromium.list zorinos-ubuntu-drivers-focal.list zorinos-ubuntu-patches-focal.list
linuxmint-daily-build-team-ubuntu-daily-builds-focal.list zorinos-ubuntu-stable-focal.list

Go ahead and remove these

rm -rf /etc/apt/sources.list.d/linuxmint-daily-build-team-ubuntu-daily-builds-focal.list

rm -rf /etc/apt/sources.list.d/


sudo apt --fix-broken install

sudo apt update

sudo apt install nemo

1 Like

mike@mike-ROG-Strix-G731GT-G731GT:~$ linuxmint-daily-build-team-ubuntu-daily-builds-focal.list
linuxmint-daily-build-team-ubuntu-daily-builds-focal.list: command not found

The above^

Where do I find these ??????

You copy and paste them into terminal. One at a time.

mike@mike-ROG-Strix-G731GT-G731GT:~$ rm -rf /etc/apt/sources.list.d/linuxmint-daily-build-team-ubuntu-daily-builds-focal.list
rm: cannot remove '/etc/apt/sources.list.d/linuxmint-daily-build-team-ubuntu-daily-builds-focal.list': Permission denied

Both of them were permission denied

sudo rm -rf /etc/apt/sources.list.d/linuxmint-daily-build-team-ubuntu-daily-builds-focal.list

sudo rm -rf /etc/apt/sources.list.d/

mike@mike-ROG-Strix-G731GT-G731GT:~$ sudo apt install nemo
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nemo : Depends: libnemo-extension1 (= 4.4.2-2ubuntu2) but 5.6.0-unstable-202211211036~ubuntu20.04.1 is to be installed
Depends: nemo-data (= 4.4.2-2ubuntu2) but 5.6.0-unstable-202211211036~ubuntu20.04.1 is to be installed
Recommends: nemo-fileroller (>= 4.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Nemo is now installed ..... under fix broken packages I forgot to copy and past the command for them to bee removed ...... I normally do that when it says they are no longer needed ...... why I didn't this time I don't know ......

Thanks Aravisian take a break I'll work on getting Nemo swapped with Thunar in a bit ......

1 Like

Thank you sir for your patience and knowledge ...... I won't trouble you any more today or rather tonight your time ...... get some sleep you deserve it ...... :+1: :smile:

I like that wallpaper.

1 Like