How to remove-skip-hide the grub menu

This post was flagged by the community and is temporarily hidden.

You should have these settings in /etc/default/grub:

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden    
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

These work on mine to avoid the menu. But if there is another OS detected by grub, you will get the menu regardless, I believe.

1 Like

Hello, mate :wink:


Thanks for answering.
My grub file is just like yours as you can see below:



What must I change to skip grub menu automatically?

When you made the changes to your grub, did you update grub to use the new changes?

1 Like

Yes, mate.
I ran the sudo update-grub

And this also applies to reversing any changes back to the original values. I would run sudo update-grub again just to be sure they are reversed in the boot menu itself (/boot/grub/grub.cfg).

1 Like

Thanks for answering, mate.


I updated the grub, (sudo update-grub), everytime that I made any changes on the grub file.
As I have only a single operating system, I would not like to have to press the Enter button to start the Graphical Environment.
What I do not understand is that GRUB_TIMEOUT=0 value is already ZERO. Why the Grub menu insists to appear?

A user of Ubuntu had a similar issue to yours and the best solution might be this:

"The following in /etc/default/grub works for me. You still get a pause, in case you want to override, but it should remain hidden.

GRUB_TIMEOUT_STYLE="hidden" GRUB_TIMEOUT="3"

p.s. The menu will appear if you press and hold Shift during the Grub timeout period."

[Source: https://www.reddit.com/r/linuxquestions/comments/kz6vl6/even_after_setting_grub_timeout_to_0_i_still_see/]

In your case you could chabge 3 to 1 and see if that works. However it must be said that it really should be five to ensure the journaling system does not get corrupted. Both Windows NTFS and GNU/Linux Ext4 FS are journaling systems that need to have a mininum boot time of 5 seconds but default settings are usually 10. My Devuan 3.1.1 is preconfigured to the safe minimum of 5 seconds.

1 Like

Hello, mate.


In my grub file these parameters already exist and in line GRUB_TIMEOUT the value is 0.

I know, I was suggesting you change the zero to 3 and see if it gets hidden but you just get a pause according to that post on reddit.

I tested the value 2 but nothing happened, mate.

See if using Grub Customiser works any better for you - it's available in the store:

1 Like

Thank you, mate, but I definitely give up.


Thousand thanks for everybody who tried to help me.

Looks like it has been dropped.

1 Like

If you are still reading your thread:

If you must press Enter to move beyond the menu, this is not normal either. If you wait for the timeout to expire your system should proceed to boot the default menu entry (the first one) regardless of whether the menu is hidden or not. (unless you press some key other than Enter when you reach the menu - this cancels the timeout.)

If this behavior really bothers you, one possible 'cure' might be to reinstall grub and see if that corrects the problem.