How to run EXEs with Wine, without getting the confirmation screen?

Hello everyone, I'm new on the forum.

I am using Zorin OS 16 Core 64 bit
I have installed Wine, and it worked fine, but I have a question...

When I run an EXE, every time I get a confirmation screen that says the following....

Filename.exe is an unknown Windows application.
Your computer and personal data can be vulnerable by running applications from unknown sources.
Some Windows applications may not be compatible with Windows Application Support.

every time I have to give the permission with the button...

Run FileName.exe in all ways.

Is there a way to make this EXE run without this confirmation window appearing???
Since with some distributions of both debian and ubuntu, which I don't remember now, it runs it directly for me.

I'm a programmer, and every time I compile source code, I have to give him permission to test it.

I don't know if I have to log in as an administrator, or if there is a way to configure it.

Thanks a lot

1 Like

Make a shortcut to it. POL is an easy way.
Or: How to create Wine shortcut? - Ask Ubuntu

Basically, that keeps popping up because it doesn’t have explicit instructions to start it with Wine - it’s asking you if it should.

1 Like

Thank you Carmar

But PlayOnLinux doesn't work for me, I know it, but I can't be adding each exe to PlayOnLinux, think that in programming, you have to program and run the EXE to see if it works.
In Debian this window doesn't appear, and I don't remember that other distros also executed it directly for me, I think it's more about setting permissions or something else.

If it is for an installation of a program, nothing happens, but if it is to test the executables that you compile when you program, it is annoying to have to accept each time.

1 Like

Right click EXE -> Properties -> Open With -> select Wine Windows Program Loader.
See if that does the trick.

1 Like

Thank you Carmar.

If there are spelling errors, it is because I use Google Translator, I am Spanish.

I Make this with right click

Captura de pantalla de 2022-01-16 20-54-20

This way it doesn't even run it, it gives me an error.

I think I need to install something from Wine, I don't know if it will be WineHQ or some other tool.

It may be that in Debian this message does not appear, and in Ubuntu it does ???, or it has nothing to do with it ??

What’s the output of wine —version? (Those are 2 dashes before ‘version’ not 1).

PS - thanks for using the translator.

wine-5.0.3 (Ubuntu 5.0.3-3+zorin2)

Hmm. That should work fine.
Ok, I missed your pic earlier.
So, from my instructions here: How to run EXEs with Wine, without getting the confirmation screen ?? - #4 by carmar
When you right click on the EXE file you get a menu, at the bottom is Properties, when you left click on Properties, you get a window with one tab being Open With?

Another way to that is Right click EXE —> Open With (second choice from top) -> Other Application -> select Wine Windows Program Loader

I’m using Nemo instead of Nautilus/Thunar but the menus will be about the same.

Btw, if you manage to get the above menus but do not see Wine Windows Program Loader, then click Other Application (“Ver todas..”) and it should give you a field at the bottom to enter a custom executable. Here you will enter /opt/wine-stable/bin/wine and click Ok. Then go back to try clicking the EXE file again.

No, I only get these options.

  • Run Program
  • Install one Aplication of Windows.

I don't see the Wine Windows program loader, but when I installed and tried other linux distros, I've come to see it, maybe also in Zorin, maybe I have to update Wine.

I also don't get any text box, so I can write /opt/wine-stable/bin/wine

When do you do it??? you run the EXE without getting the window that I get???

If you can send me screenshots

I’m responding from my phone right now otherwise I would have sent screens of what I see.
It will look like the pic here: 18.04 - multiple 'open with' applications in right-click context menu with nautilus/filemanager-actions? - Ask Ubuntu

Look at: [HOW-TO] Set default applications in xfce - it’s for xfce but the instructions should apply even on gnome.

You can also consider editing ~./config/mimeapps.list , see: Override the default registered application for individual users

Sorry, unfortunately I’m familiar with the GUI methods but not the other two I listed here.

Thank you Carmar.
I'll look online to see if anyone has found it.

The strange thing is that it didn't happen to me with a debian-based distro. I will try on my father's computer that has mint, but I don't know if it will have wine installed.


These are the screens that come out, I don't know if they would have been placed in order.

The last one is the one I was telling you about, which asks me for authorization every time I run an EXE

Unfortunately, I have never tried Debian, so I cannot opine.
It has been too long since I was on Core for me to remember the Nautilus configuration. Does clicking “Buscar..” allow you a choice?
Sorry, I’m probably not helping.

Do not worry!!!
If you have helped me :), some things I did not know.

That's what happens when you boot into other operating systems.

I will do something wrong, since you say that you can run an EXE without getting the confirmation screen, I think it was the last of the 4 that I have put.

In any case, with time I'll get it, I'm sure it's a configuration thing, or that I have to enter as an administrator, who knows!

I need that, because I make programs in FreeBasic for Windows, but I do it from Linux, since with XP I was limited to depending on which programs no longer worked for me, like Thunderbird, or being able to enter Google Sites, since the Firefox browser of XP was no longer supported.

In fact, my 2 children have Windows 10, and it is super slow for them, so I am also going to install Linux for them, surely Zorin OS, since they like it and so we will use the same distro for all 3.

Although it is difficult because they are in Ecuador, and I am in Spain, we do everything for TeamWeaver.

Thank you, greetings from Mallorca.

1 Like

Ok, finally got around to getting you the screenshots.
I'm on Z15 XFCE (Lite), Nemo file manager, Wine 6, but it shouldn't make a difference. Using red and green rectangles to show what selections I was referring to earlier.

If you select Open With

If you select Properties

Hello carmar

I was able to do it, install Wine 6.X with the console following these steps...

with Wine 5.0 maybe it always asked permission

It was for Mint 20, but it worked for me in Zorin

Now if the menus that you told me appear.
:smile: :smile:


1 Like

Glad to hear. If it works now then please mark this thread as solved.

Update - thanks for marking. I changed the marked solution from this post to the now marked one because I think that was the resolution. If you feel otherwise, please feel free to change again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.