How to run incognito browser by default?

It's been awhile since I used Zorin, now I'm using Core Zorin on my Macbook. The way to install app, and do things with app is kinda changed, in my point of view.
So, How do I run Incognito by default for Chromium Web Browser?

what I tried:

  • right click the chromium and see if I can change and info and put some "--incognito" word on it, but all I see are "Open Tab" options, "Remove from Favorite", and "Show Detail" which bring me to the App Store when clicked
  • open terminal and locate chromium, which found zero result
  • locate file manually using nautilus /, searched /usr/bin, and many other folders and got none

You should be able to set it up with the second post instructions:

**Edit: **
Use the third post, my mistake

cannot find "chromium-browser.desktop" in /usr/share/applications or in /home/myname/.local/share/applications


Try this:

There are two steps,

  1. Run sudo update-alternatives --config x-www-browser and select /usr/bin/chromium-browser. This will make Chromium your system's default browser.
  2. Run sudo -e /etc/chromium-browser/default (edit as root), and change the line that reads CHROMIUM_FLAGS="" to CHROMIUM_FLAGS="--incognito".

That's it. Changes are instantaneous.

Also, if you ever want to open chrome without incognito mode, just hold Ctrl + n in incognito mode.

Has it installed as Flatpak or Snap?
You can check using terminal or, Open Software Channel, click Installed button - scroll to Chromium in the list and click on it.
View the source button on the titlebar /toolbar or scroll down to Details and look at source package.

If it's snap you'll have to use that directory in place of /usr/ applications/ chromium-browser.... forgive me I'm a bit stretched

update-alternatives: error: no alternatives for x-www-browser

Please see aravisian's post

source is "snap store"

title bar has no "source" button, only "Launch", "Remove", "Permission"

That's why.
Snap packages are isolated and sandboxed.

Every method I know of- and Harvey already listed above- works on Non-Snapd chromium.

Honestly... if it was me, I would snap remove chromium and then install the Chromium .deb package to reinstall it.

On Software source: Titlebar- the very top:

hmmm....somehow i cannot screenshot , i want to show you that my screen has no source on top.
I'm using Zorin Core
I just found out screenshot bug right now...sigh

Zorin core 15.3 or Zorin Core 16 beta?

dunno, how to find out?

Installing Zorin OS 16 beta would have been a recent and proactive effort. I think if you had installed it, you would know it. :wink:

oh found it, 15.3

i'll make a new post about this screenshot thing