HP Elitebook Touchpad not working correctly

Hi from Vienna!

I just have done my transformation from Windows to Linux Zorin 17 and I am happy. The installation on Intel NUC works perfectly and also the installation on my HP Elitebook is ok with just two minor issues (HP EliteBook 840 G5 | 256 GB | i5-8350U | 1920 x 1080)

  • On the touchpad, the leftclick works on the buttons above the touchpad as well on the touchpad itself. The rightclick only works on the right button over the touchpad but not on the down right side of the touchpad.
  • The fingerprint sensor (the ability to select fingerprint as authentication) does not work. I am not able to activate this function in my user profile.

These issues are no showstoppers for me but it would be nice to solve them :slight_smile:
Please be patient: 50+ here who is fully new to Linux :slight_smile:

Thanks!
Peter

Hi and Welcome to the forum HerrGrau! Zorin is a fork of Ubuntu, and since Ubuntu 18.04, gestures for right-click changed to a double-tap, but according to this article there is a workaround:

In respect of the fingerprint reader, remember the hardware was built for that other OS! Can you please open a Terminal (Menu | Utilities | Terminal) and enter:

sudo lshw -C usb

and post back the results. Danke!

Good morning!

the hint with the tweak tools worked perfect. Thanks for that.
When I enter the command

sudo lshw -C usb

it does nothing. I have added a screenshot to document that :slight_smile:

Thanks for your help!
Peter

Try

lsusb

1 Like

Hi!

Thanks for the hint, but that also does not do the trick. For one second, it shows the word "usb" in a new line, which the disappeare. The function to logon with fingerprint is still not provided as you can see in the screenshot attached.

Thanks,
Peter

This is odd. Even if your fingerprint device did not show in the list, your USB Ports and root hub should show and remain printed in the terminal.

If we assume an odd error; can you proceed to trying these three separate commands in terminal?

sudo apt install fprintd libpam-fprintd

fprintd-enroll

sudo pam-auth-update --enable fprintd

Good morning!

Oi, this is so strange: Here is a print of the terminal with the commands and what it says to me :slight_smile:

peter@pnaclient:~$ sudo apt install fprintd libpam-fprintd
[sudo] Passwort fĂĽr peter:
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut… Fertig
Statusinformationen werden eingelesen… Fertig
fprintd ist schon die neueste Version (1.94.2-1ubuntu0.22.04.1).
fprintd wurde als manuell installiert festgelegt.
libpam-fprintd ist schon die neueste Version (1.94.2-1ubuntu0.22.04.1).
libpam-fprintd wurde als manuell installiert festgelegt.
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
cabextract icoutils jq libjq1 libmspack0 libonig5 libwmf0.2-7-gtk
libwxbase3.0-0v5 libwxgtk3.0-gtk3-0v5 python3-natsort python3-numpy
python3-wxgtk4.0
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 4 nicht aktualisiert.
peter@pnaclient:~$ fprintd-enroll
Impossible to enroll: GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No devices available
peter@pnaclient:~$ sudo pam-auth-update --enable fprintd
peter@pnaclient:~$ fprintd-enroll
Impossible to enroll: GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No devices available
peter@pnaclient:~$ ^C
peter@pnaclient:~$

Sorry, it is in german

Best regards,
Peter
PS: There is definitly a device for fingerprint as I have used it when there was win11 installed on the same laptop :slight_smile:

Can we go back to reporting the results of:

lsusb

Aravisian posted the correct command. The reason why we need this is because fingerprint readers get registered in the kernel as usb devices. It will provide us with information as to the hardware used as some fingerprint readers will not work with the Linux kernel.
Don't know if this guide helps. Would be curious to know if works after creating a second user as a Standard user:

https://www.thinkpenguin.com/gnu-linux/how-use-fingerprint-reader-gnome

If yours is one the Linux kernel does not support the only alternative would be to purchase a GNU/Linux compliant external fingerprint reader such as this:

https://www.thinkpenguin.com/gnu-linux/optical-usb-fingerprint-reader-gnulinux-edition-tpe-f4500

I was using now the command lsusb (I might mistyped it when I tried it 1st:

peter@pnaclient:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0408:5411 Quanta Computer, Inc. HP HD Camera
Bus 001 Device 004: ID 138a:00ab Validity Sensors, Inc.
Bus 001 Device 003: ID 8087:0a2b Intel Corp. Bluetooth wireless interface
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
peter@pnaclient:~$


Hope that helps to help :wink:
Peter

Looks like it is not supported an no drivers written for it in GNU/Linux I'm afraid:

Hi!

Thanks for checking that out. It is not the information I am happy to hear but last but not least it was not me :slight_smile:

I have also the camera for face recognition, I will check if that works anyhow ...

Thanks,
Peter

Hi, You may need to install Howdy?:

:slight_smile: Currently working on it ...