I cannot upgrade : "Sorry, password authentication didn't work.Please try again. To upgrade Zorin you need to authenticate"

Well i don't know what xrdp is so I doubt I ever tried to set it up.

Okay I did this :
sudo useradd <new_username> -G sudo

and received back:

bash: new_username: No such file or directory

And I'm also curious if you've made any modifications to system files before?
Possibly ? I don't think I have though. I am not very proficient on Linux and other than the usual colors and fonts and styles and sizes leave things alone if they work.

You need to replace the <new_username> with a name composed of alphanumeric characters, such as "test" or something else. The <new_username> in the snippet of code above was just a placeholder.

The portion <new_username> denotes your choice. For example, let's say you wanted your new username to be friedpickles. Replace the carroted protion: <new_username> with friedpickles. The carrots differentiate was is to be replaced.

sudo useradd friedpickles -G sudo

You installed Zorin OS yourself and did not make any known specific system changes, it seems more likely there is some kind of file corruption if not a possible connection error for the upgrader.
You can try

sudo apt install --reinstall ca-certificates policykit-1-gnome

Thank you ! Thanks everyone" who contributed to this I super appreciate it.

I was able to create a new user and that non-existent "user" then was able to update the laptop to 17.1 lite and get it all set up fast.

Also it seems the wifi connections is much faster on this version !

Thanks !

2 Likes

I'm glad it worked, although I'm still confused as to why this didn't work for your regular user account as it's basically setup in the same way :confused: Oh, well, if it works, it works!

1 Like