I can't connect internet on wifi


i'm happy using zorin os but i have a problem.

ZorinOS my network driver card doesn't know and i upgrade kernel manuel after then my network card working but when i connected wifi i can't ping or connect google.com or another internet website.

i added google nameserver in resolv.conf but it didn't work.

fms@Fms-RogStrix:~$ uname -a
Linux Fms-RogStrix 5.11.0-46-generic #51~20.04.1-Ubuntu SMP Fri Jan 7 06:51:40 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
fms@Fms-RogStrix:~$ sudo lshw -c network
  *-network UNCLAIMED
      description: Network controller
      product: MEDIATEK Corp.
      vendor: MEDIATEK Corp.
      physical id: 0
      bus info: pci@0000:2f:00.0
      version: 00
      width: 64 bits
      clock: 33MHz
      capabilities: pciexpress msi pm cap_list
      configuration: latency=0
      resources: iomemory:620-61f iomemory:620-61f iomemory:620-61f 
      memory:622c100000-622c1fffff memory:622c200000-622c203fff 

In your BIOS settings, is secure boot disabled?

Yes disabled for kernel reasons

Can you help me please ?

Are you able to temporarily connect using Mobile Hotspot?
Open Software & Updates and move to the Additional Drivers tab. It will run for a moment, searching. When it has finished, it should show if any drivers are available.

unfortunately this problem not solved.

I have a question if i buying zorin os pro does it solve this problem ?

Doesn’t seem like others are having luck even with newer kernels: networking - How can I get MEDIATEK Corp. Device 7961 to work? - Ask Ubuntu

What’s your output for sudo lspci?

i tried and unfortunately not solved.

uname -r
sudo lspci | grep -i mediatek
0000:2f:00.0 Network controller: MEDIATEK Corp. Device 7961

Here it seems it worked with kernel 5.12: networking - Wifi not working on ASUS rog zephyrus g14 2021 - Ask Ubuntu
It’s worth a shot.

5.12 kernel version doesn't know wifi chip i try 5.14.9 i get an error

I tried another solution but not worked.

Wifi work but not internet for kernel 5.14.9 or hight kernel version.

I tried live USB Zorin 16 core on Sony Vaio, WIFI worked flawlessly. It does not work on Macbook pro. But MANJARO 21 worked perfectly on Macbook. So i tried UbuntuStudio on Macbook too, it does not work either. I think it is a problem of UBUNTU.


I had the same problem, my laptop came with realtek wifi, and I replaced it with intel as a solution. and now everything is working out of the box.

i'm a linux system administrator and i solved this problem but it still took a long time to solve this problem and it will be very difficult for normal users to solve it.

i will buy macbook soon :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.