I have no sound on my thomson thomson thbk2-12 32b500


All is in the title , i have an thomson notebook , i revived it using Zorin os lite pro , then it became too laggy , i installed the base version of zorin os lite 16, works well but i have no sound , updated it , still same problem , and it doesnt show any third party drivers in the settings .

thanks in advance !!

Gday @theawesomerb , Welcome to the community!

Can you show the result here for this please,

sudo lshw -C multimedia

Also check Alsamixer for mute or low volume. In the terminal;

1 Like

thank you for your answer @Ocka, here is a capture of the command :

what should i do next ?

1 Like

@Storm , thanks for your answer , the message shown is : the device has no commands

thank you in advance for your help !

1 Like

In Alsamixer, (M) at the bottom = mute/unmute.
!st select your audio card F6
Then F3 for Output.
And F4 for Input.
Also F5 for Everything.
Check that they are all "Un-muted"

You can also see this from the "Volume " Icon on Taskbar.
Check output setting & Configurations.

when i selection intel HDMI/DP LPE Audio , it shows : this audio device has no commands.
when i select sof-bytcht es8316 : i can in fact go around with F3 F4 F5 but nothing really works , also nothing is muted.

1 Like

Also check in "pulseaudio controller" IN the above photo from speaker icon in taskbar.
Check in "Configuration" TAB,
Is set to "Analogue Stereo Duplex" .
In "Output" TAB ,
Make sure you have "Speakers" selected.

(My photo is in a VM, so Output is set to Line Out.)
Do you have a headset,,, do you get sound via headset?

ADDED: here's my setup:

@theawesomerb Can you post a screenshot of your Alsamixer.
If you see [Auto-Mute] and [Loopback] channels listed (as you can see on Ocka's last screenshot), try changing those settings i.e. Disabled or Enabled to see if any effect.

@Ocka : as u can see in my screenshot : all outpout 'unplugged'

@zabadabadoo :

there u go , when i select the sound card it show those two , the intel HDMI shows no controls as my first screenshot , the seconds shows what is in the second screenshot however nothing works

can you shrink alsamixer please Ctrl + - to shrink so we can see all like in my post
Please Select your audio card. thenF5

The photo with "Unplugged" is your "HDMI" not speakers/headset.

First thing I can see from your 2nd alsamixer sceenshot is [Speaker] set Muted i.e. "MM". Move the cursor across to [Speaker] channel, hit M to unmute and up-arrow to increase volume.

There should be a [Master] channel on the left, but we cannot see all of your alsamixer in those screenshots. See the stack of arrows on the right of the alsamixer, they are actually pointing to more sound channels that you should see if you click there.

As @Ocka has asked. Hit F5 to show All channels on one screen and post a screenshot or photo of the whole thing.

1 Like

thanks @Ocka and @zabadabadoo , here is the screen cap as suggested , i unmuted everything , still doesnt work , what would be the next step ?

1 Like

We are not seeing all your sound channels in that photo.
Please do the above F5 before screenshot, to show All (Tout) channels.
Also there are more channels as depicted by arrows on right edge of the screen. You need to scale the screen to show all of them in a single window, or take multiple screenshots.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.