I messed up

I wanted to install Aseprite in my laptop. I found that linux users can complie it from sourc for free. I did not know how to do it so I searched how to do it on the internet and found this webpage: How to install Aseprite on Linux

And it tried the commands said there and while I was running git clone https://chromium.googlesource.com/chromium/tools/depot_tools.git the downloading stopped for a few seconds and then continued the downloading process. But my system became too unresponsive and every click I use just opened whiskermenu. Pressed my power button and I tried to press shutdown using my mouse but it did not work anymore. I used my keyboard and pressed shutdown. I booted it up again and when I press my right mouse button I have to like press it a hundred times to get it to work. My xfce4 panel is missing and when I run 'xfce4-paneI -r' in my terminal I get

I restarted my laptop again and after I opened the terminal from right click menu, the window buttons like close minimize ect are not visible anymore. The whole title bar is missing.

Please help.
EDIT: One more thing, on my second boot my laptop showed a terminal with the following on boot

Also I found my Zori OS 16 Live USB that I used to install. Do I have any way other than reinstall to get my it back to working state.

And one more thing, if all these problems does not end up being the result of some mistake that I unknowingly made during installation, I am putting that tutorial to the wall of shame.

It looks like XFDesktop is not running - XFWM4 certainly isn't.
You might try

sudo apt install --reinstall zorin-os-lite-desktop zorin-os-lite-core

Running that command shouldn't destroy your DE... Could it be bad sectors on the HDD?

1 Like

Nope, it doesn't look like it worked.

I did a scan with smartmontools and passed.

The instructions say to install:

sudo apt install -y g++ cmake ninja-build libx11-dev libxcursor-dev libgl1-mesa-dev libfontconfig1-dev git

Looking over that list, that contains things Zorin comes with and some things that should be safe. But... You seem to be having x11 troubles.
Try

sudo apt install remove --purge libx11-dev libxcursor-dev libgl1-mesa-dev libfontconfig1-dev && sudo apt --fix-missing update

I had taken a note of the things that were going to be newly installed when I ran that command

cmake cmake-data libjsoncpp1 librhash0

Should I only remove these or should I remove all of them?

Do not remove cmake, cmake-data, libjson, ninja, git or librhash at this time. Try removing just the -dev packages.

I think it was not removed

sudo apt install --purge --remove libx11-dev libxcursor-dev libgl1-mesa-dev libfontconfig1-dev && sudo apt --fix-missing update
Reading package lists... Done
Building dependency tree
Reading state information... Done
libfontconfig1-dev is already the newest version (2.13.1-2ubuntu3).
libxcursor-dev is already the newest version (1:1.2.0-2).
libgl1-mesa-dev is already the newest version (21.2.6-0ubuntu0.1~20.04.1).
libx11-dev is already the newest version (2:1.6.9-2ubuntu1.2).
The following packages were automatically installed and are no longer required:
gnome-settings-daemon-common gnome-system-monitor libdecoration0
libemeraldengine0 libprotobuf17 zorin-os-feedback
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 53 not upgraded.
Hit:1 Index of /ubuntu/ focal InRelease
Hit:2 Index of /ubuntu/ focal-updates InRelease
Hit:3 https://brave-browser-apt-release.s3.brave.com stable InRelease
Hit:4 Index of /ubuntu/ focal-backports InRelease
Hit:5 Index of /ubuntu focal-security InRelease
Hit:6 Index of /aravisian/gtk-theming/ubuntu focal InRelease
Hit:7 Index of /repos/vscode/ stable InRelease
Hit:8 Index of /linuxuprising/apps/ubuntu focal InRelease
Hit:9 Index of /stable/ focal InRelease
Hit:10 Index of /patches/ focal InRelease
Hit:11 Index of /zorinos/apps/ubuntu focal InRelease
Hit:12 Index of /apps/ focal InRelease
Hit:13 Index of /drivers/ focal InRelease
Hit:14 Index of /zorinos/drivers/ubuntu focal InRelease
Hit:15 Index of /zorinos/patches/ubuntu focal InRelease
Hit:16 Index of /zorinos/stable/ubuntu focal InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
53 packages can be upgraded. Run 'apt list --upgradable' to see them.

Jeslin... it was 3am...I am sorry, I failed you. I typoed.

sudo apt remove --purge libx11-dev libxcursor-dev libgl1-mesa-dev libfontconfig1-dev && sudo apt --fix-missing update

That did not work either.

get some sleep man....

Sleep is for the weak. I am fine. Why are my ears buzzing?
I said I'm fine. Stupid dolphin ate my doughnuts.

Now that you removed those packages, try reinstalling the Zorin OS desktop
along with:

sudo apt install --reinstall xserver-xorg-core zorin-os-lite-desktop && sudo dpkg --configure -a

Reinstalling worked.

Reinstalling the OS or the Desktop?

The OS.

Oh now I realized... You asked me to reinstall my desktop. Stupid me :man_facepalming:

Thought I was the sleepless braindead one?
I even included the handy terminal command and everything...

Yep, you are right. I've been sleeping a lot less and doing dumb stuff this whole week.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.