I tried to run the CryEngine editor on Linux

Hi,

I have a story to tell you about attempting to run a Windows only app on Linux - the CryEngine editor.
For those who don't know, CryEngine is essentially another game engine used in games similar to Unity and Unreal Engine.

First, since I'm using Ubuntu now, I installed WINE 8.0 (Ubuntu doesn't come with WINE unlike Zorin), then got the installer for CryEngine, which I opened the next day. When I opened it, it said 'No Internet Connection'. I thought wierd (callback to the PowerDVD incident I had), but then I realised I disabled Wi-Fi! Whoops!

Anyway, when I opened CryEngine, I had to install an editor (same deal with Unity), but when I tried to open the editor (Sandbox.exe), I couldn't - it did nothing. I opened it in the terminal and... what do you know? Missing library (mfc140.dll)! I couldn't find anything about this on the internet, so I gave up.

The next day, I installed Winetricks to install that library and opened Sandbox.exe again, both directly and in the terminal. It got further than before, but unfortunately, it hanged on the initialisation screen. The terminal showed:

⁠0168:fixme:d3d_shader:shader_sm4_read_shader_data Unexpected immediate constant buffer size 4112.
0168:err:ole:RegisterDragDrop COM not initialized
0168:err:ole:CoLockObjectExternal apartment not initialised

Now before you tell me so, I know that some apps don't run on WINE - I just thought this one was an exception. So yeah.

This may be more helpful than Wine:
https://docs.cryengine.com/display/SDKDOC4/CRYENGINE+on+Linux

Yeah, I can't actually.

It says './cry_waf.sh: No such file or directory'.

Did you download the files for the engine?
Are you running the command in a terminal cd'd into that directory?

Not quite sure where to do that.

I am running in terminal.

I think I changed to root.


Should we... change the category of this thread?

The command you are running is telling the system to Run A File. In order for it to see the file you wish to run, you must run that command in the Same Directory that the file is in...
Or...
Run the command with the path to the file included.

For example, let's say you want to run example.sh which is located in your Downloads folder.
Method 1:

cd ~/Downloads

./example.sh

Method 2:

./home/$USER/Downloads/example.sh

Sure; done.

Oh... Well, I took a look for it and I found:

The link I gave you is... outdated. Cryengine has gone fully Proprietary and only offers and .exe launcher and installer and has given Linux the finger.

What about using Unreal Engine?

Unreal Engine, since I have a weak graphics card (Integrated 1GB Intel UHD Graphics), it crashes upon load. I do happen to have Unity however, which works fine.

I tried CryEngine because I wanted "a change of scenery" if you will.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.