Installed KSpaceDuel and unable to uninstall it

I was trying to take a break from work, and installed KSpaceDuel. The drop down was default on "Snap Store", but I selected "Zorin OS" instead. My thinking was that I did not want to use "Snap Store" because I consider to maybe remove "Snap" in the future.

Anyway, I installed KSpaceDuel. It was not the best game. :slight_smile: So I wanted to uninstall it, but is not able to, I get this error:

Unable to remove KSpaceDuel

The following packages have unmet dependencies:
  gstreamer1.0-vaapi: Depends: libva-wayland2 (>= 1.3.0) but it is not going to be installed

Anybody know what to do? I am finally very happy with my system (Zorin OS 17), so I am a little afraid to mess things up by experimenting.

One thing I did try to solve it, was to install KSpaceDuel with "Snap Store". My idea was that maybe if I installed it with "Snap Store", I would then be able to uninstall KSpaceDuel from "Zorin OS", and then finally uninstall from "Snap Store". But when trying to install with "Snap Store" I get thiss error:

Unable to install kspaceduel

(null): cannot install "kspaceduel": snap "kspaceduel" assumes unsupported features: snapd2.58.3 (try to refresh snapd)

This was so stupid of me. I am not a gamer. Totally unnecessary of me to install a game. :slight_smile:

Can you open a terminal and run

sudo apt update && sudo apt upgrade

You will be prompted to accept any packages that need to be upgraded. Please read carefully the output in case there are some errors reported, and if everything goes well accept by pressing Y. Then you can run:

sudo apt remove kspaceduel

I just installed and uninstall this myself and there were some mentions of those packages that you mentioned in the error: "gstreamer1.0-vaapi" and "libva-wayland2" but I'm guessing it's just some outdated dependency for some reason.

1 Like

Well clearly the Snap version did not install. This might be a way round the installed apt version. Go to Software and install Synaptic Package Manager. Once installed, launch it (you will need to provide your login password to elevate you to root), use the Search function for KSpaceDuel and when it comes back you should see the little square in front filled with a green colour, indicating it is installed. Right-click the square and select 'mark for complete removal', then click on the 'Apply' button on the menu bar at the top.

1 Like

Thank you so much @zenzen , this solved my problem. I have marked your reply as "Solution". Below is output of the commands

xx@xx:~$ sudo apt update && sudo apt upgrade
[sudo] password for xxx:         
Hit:1 http://no.archive.ubuntu.com/ubuntu jammy InRelease
Hit:2 http://no.archive.ubuntu.com/ubuntu jammy-updates InRelease                                                                         
Hit:3 http://no.archive.ubuntu.com/ubuntu jammy-backports InRelease                                                                       
Hit:4 http://archive.ubuntu.com/ubuntu jammy InRelease                                                                                    
Hit:5 https://ppa.launchpadcontent.net/zorinos/apps/ubuntu jammy InRelease                                                                
Hit:6 https://ppa.launchpadcontent.net/zorinos/drivers/ubuntu jammy InRelease                     
Hit:7 https://ppa.launchpadcontent.net/zorinos/patches/ubuntu jammy InRelease
Hit:8 https://ppa.launchpadcontent.net/zorinos/stable/ubuntu jammy InRelease
Hit:9 https://packages.zorinos.com/stable jammy InRelease                   
Hit:10 https://packages.zorinos.com/patches jammy InRelease
Hit:11 https://packages.zorinos.com/apps jammy InRelease
Hit:12 https://packages.zorinos.com/drivers jammy InRelease
Get:13 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Fetched 110 kB in 2s (47,7 kB/s)     
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  gstreamer1.0-vaapi libwmf0.2-7-gtk
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

In above I notice this wich mention "gstreamer1.0-vaapi" wich was also in the error message;

The following packages were automatically installed and are no longer required:
  gstreamer1.0-vaapi libwmf0.2-7-gtk

Then did your next command to uninstall:

xx@xx:~$ sudo apt remove kspaceduel
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gstreamer1.0-vaapi kded5 kdoctools5 keditbookmarks khelpcenter kinit kio kpackagelauncherqml kpackagetool5 libaribb24-0 libcddb2
  libdc1394-25 libdca0 libdvbpsi10 libdvdnav4 libebml5 libfaad2 libgrantlee-templates5 libhfstospell11 libixml10 libkate1 libkf5archive5
  libkf5attica5 libkf5bookmarks-data libkf5bookmarks5 libkf5completion-data libkf5completion5 libkf5crash5 libkf5declarative-data
  libkf5declarative5 libkf5doctools5 libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5
  libkf5iconthemes-bin libkf5iconthemes-data libkf5iconthemes5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data
  libkf5jobwidgets5 libkf5js5 libkf5kdegames-data libkf5kdegames7 libkf5khtml-bin libkf5khtml-data libkf5khtml5 libkf5kiocore5
  libkf5kiogui5 libkf5kiontlm5 libkf5kiowidgets5 libkf5kirigami2-5 libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5
  libkf5package-data libkf5package5 libkf5parts-data libkf5parts-plugins libkf5parts5 libkf5quickaddons5 libkf5solid5 libkf5solid5-data
  libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5syndication5abi1 libkf5textwidgets-data libkf5textwidgets5 libkf5xmlgui-bin
  libkf5xmlgui-data libkf5xmlgui5 liblua5.2-0 libmad0 libmatroska7 libmpcdec6 libopenal-data libopenal1 libopenmpt-modplug1
  libphonon4qt5-4 libphonon4qt5-data libplacebo192 libprotobuf-lite23 libproxy-tools libqt5printsupport5 libqt5qmlworkerscript5
  libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5quickwidgets5 libresid-builder0c2a libsdl-image1.2 libsdl1.2debian libsidplay2
  libsndio7.0 libspatialaudio0 libssh2-1 libupnp13 libva-wayland2 libvlc-bin libvlc5 libvlccore9 libvoikko1 libwmf0.2-7-gtk libxapian30
  phonon4qt5 phonon4qt5-backend-vlc qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-newstuff
  qml-module-qtgraphicaleffects qml-module-qtqml-models2 qml-module-qtquick-controls2 qml-module-qtquick-layouts
  qml-module-qtquick-templates2 qml-module-qtquick-window2 qml-module-qtquick2 sonnet-plugins vlc-data vlc-plugin-base
  vlc-plugin-video-output
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  kspaceduel
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 1 986 kB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 310191 files and directories currently installed.)
Removing kspaceduel (4:21.12.3-0ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...

So it seems it worked! Only thing is that I went over to "Software" in GUI to check that the game was not listed as installed anymore. However it was still listed there, but this time the "Trash can" icon next to it was replaced by a button with the text "Uninstall". So I clicked it, and it was removed (very fast, only two seconds maybe). Maybe this last step was not needed, I mean, it could be cached some how and then maybe automatically removed from "Software" after next reboot of computer.

Anyway, your reply was the solution. Thank you so much! I did try to look for solution in Google before posting. Thanks!

Edit: In the last output above it says:

The following packages were automatically installed and are no longer required:
[cut]
Use 'sudo apt autoremove' to remove them.

Should I run sudo apt autoremove to remove these not needed packages, or is it not safe? Maybe it will remove other things that was not related to the game?

I suspect you removed some residual files with that last action. To be completely sure you can run the following:

sudo apt autoremove

All those packages that were listed before as no longer required will be deleted.

1 Like

Thank you again. You must be a mind reader, as you posted your last message a few seconds before I asked about the same thing in my "Edit" above. I have done the autoremove command now, and everything is looking good. :slight_smile:

1 Like

I do some mind and fortune reading on the weekends for a little extra income :crystal_ball: :brain:

For future reference the advice from @swarfendor437 is pretty good as the Synaptic package manager is more powerful, albeit less polished visually, than the Software Store. You can remove files more easily that way if you are not interested in reaching for the terminal in these situations.

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.