Installed Zorin OS 15 on Lenovo does not boot

I have installed a fresh version of Zorin OS 15 on my Lenovo Laptop (4GB RAM, 500 GB HDD). I have used entire disk for installing Zorin OS. No Windows partition. The installation was successful. However, when it restarts, it just hangs and goes straight to the Boot Loader window and hangs. I clicked on the “ubuntu” in the boot loader options, but it just hangs.

I have installed Ubuntu (long ago) in the same laptop and it never had any issues. Please help.

You may need to repair grub:

Hi, also surprised it states ubuntu and not Zorin - hangover from the Ubuntu install?

I do not know why that is showing as “ubuntu”.

It is very surprising that grub menu needs to be repaired. If I recall, such repair is done if I using Linux alongside Windows partition.

This is where my logic is.
Your boot is offering only the previous Ubuntu.

I have installed Zorin OS by removing Windows 10 (which is the last OS installed in my Laptop). It had no partition for Ubuntu or any linux systems.

After installing Zorin OS, ubuntu comes in Boot Loader.

Have tried Boot Repair by going through the tutorial. Same result. No Grub menu… it restarts with the Boot Loader and hangs there.

Is this a fresh install?

Yes. On a freshly installed Zorin, started boot-repair using Live USB.

Well, what I am seeing here is that you describe Ubuntu as showing in the Boot Menu. That shouldn’t happen.
You said that Ubuntu was installed in the past. It seems to me that is being referenced- somehow. Perhaps by the MBR.
Then Win10, which has Fast Boot that locks the HDD down, Secure Boot in the BIOS… Honestly, we could troubleshoot this one all day long given the oddity of it.
But since it is a Fresh install - I would encourage you to reinstall.

It does not take long to do, and this will give the opportunity to ensure everything is right from the start, each step of the way.
In BIOS ensure that you are in EUFI mode and that Secure Boot is disabled. Then, when you run the Ubiquity Installer to install Zorin OS, choose “Something else” option.
Gparted will open. In Gparted, delete any partitions you want to replace using the “-” button.
Then, select the freespace again and add it with the “+” button and choose to format the drive. Ensure your Mount point is set to

/

2 Likes

Finally it has boot up with Zorin OS. A full reinstallation worked. Thank you.

2 Likes