Installing PSPP on Zorin OS 16

Hello, I'm new to Zorin and would like to use GNU PSPP.
I downloaded the .tar.gz from their website and followed the steps in the "Install" text-file. The system keeps telling me that some required prerequisites are not installed. I tried to install them, but I couldn't manage to get a single one of them. Can anyone give me an advice whether and how I can get PSPP working in Zorin OS 16? Thanks in advance!

Are you currently on Zorin OS 15 or Zorin OS 16?

I'm on Zorin OS 16

That is odd. It lists gtk 3.22 or better and Zorin OS 16 is using gtk 3.24...

Open your terminal in your home Downloads directory and use wget / curl to get the necessary packages. Then you can use apt to install them:

cd ~/Downloads

wget -c
wget -c
wget -c
wget -c

sudo apt install ./libgsl25_2.6+dfsg-2_amd64.deb ./libgslcblas0_2.6+dfsg-2_amd64.deb ./libspread-sheet-widget_0.6-3_amd64.deb ./pspp_1.4.0-3_amd64.deb

wow, it actually worked! PSPP is installed on my system and running perfectly fine. Thank you Aravisian, that was very helpful! :four_leaf_clover:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.