Installing ZORIN OS on HP pavilion 15 au104nx

To clarify this:
TPM and Secure Boot should be disabled.
Fast Boot should always be disabled. Fast Boot locks the hard drive preventing read / write access in order to save a snapshot of the drive to allow for the Quick Boot.

If Dual Booting with Windows, some users may opt to enable Secure Boot. Secure Boot can interfere with some apps and drivers, like Nvidia.
Secure Boot is for Windows only. Microsoft, in good spirit, did sign off on a large number of Linux Packages to allow for dual booting, but they did not sigh off on them all. This can cause unsigned packages to be blocked at boot.

i unchecked check for updates .... disconnected wifi , tried everything

i have tried etcher , Rufus and also image iso ...
i followed every tutorial for creating bootable and its working fine on my pc .. but not on my laptop.

idk what u mean in last 3 lines

Here is everything u said ,

--> set admin password [Done]

--> On startup pressF9 this should open boot Manager, the use Ctrl+F1, Then F10 to open Advanced.

[done -- Not working]

-->In BIOS under "Main" look of operating system ( Change this to "Other" not "windows OS. [DONE]

--> Make sure you have TPM & Secure boot enabled. [DONE]

--> I believe this isn't dual boot, if correct, then also enable "Fast boot". [DONE]



Test

Check these out

It was already disabled but the guy said to enable it so i enabled it again . :frowning:

No problem - Well, at least we have tried both.

Let's focus on this, though: HP Still locked you out from making adjustments on Advanced BIOS?

yes sir

I dislike defeat. You can tell from my profile solutions count.

Nonetheless, we have ensured that the things in BIOS that may affect install are disabled.
We have ensured trying with and without checking for updates during install.
We have a BIOS settings screen that is locked down.
We have checked the .iso, the burner.

I am at a loss.

You might try a test on installing Devuan Linux as it uses a different installer method.
MX Linux may be a good choice to try.

Maybe a different Distro will have more luck.

1 Like

There is this distro called Q4OS that can be installed from a program inside windows that configures it for you, this might be the best thing to try.
(For @Aravisian, they brought back WUBI)

1 Like

Great ok,

Can you tell us the exact model of the laptop & approx age. ( eg: HP Pavilion DX360, 2011)
As im short on time & concentration atm, i may not reply until tomorrow if needed.

Ok without re-ready the posts above, i believe this is the same on other Linux distros.
So as to why we were after advanced bios (maybe to update) im not sure without scrolling back,(sorry im time restricted atm)

To update the BIOS, while you have windows running, goto HP website & download the latest BIOS,
you will need to disable bitlocker & also disable RTP (real time protection)
Then goto the downloaded file & run the install.

Alternatively, you can flash the BIOS via usb ( HP website should have instructions )
Next insert usb Zorin OS, Select "TRY" Zorin OS.
While in there please install "Gparted" (If installable this confirms your have internet, which is preferable).

sudo apt install gparted

Open Gparted:
Please screenshot or take photo's of the main drive & also click "devices"? & select the bootable usb stick. & screenshot that too please.
Other thing's to try:
Double click the install Zorin OS icon on the desktop, see if this works from this point.
i would if possible, "Install alongside windows" to start with.
Hope this may help.

Added:
Did you ever use "Bitlocker" while using windows?

Another thought:
Try BIOS in legacy mode.

2 Likes

Good Thought.

I removed the solution mark as Ocka has not given up and brought good ideas.

3 Likes

If it's an NVMe drive, sometimes referred to as M2 SATA drives, ensure it's running in AHCI mode in the bios. Linux doesn't like dealing with them in an array mode (RAID) for whatever reason.

1 Like

Some motherboard on laptops not recognized some nvme.
They recognize some type nvme but not all.

I am attaching some images which confirms the exact model and age of my laptop.

AGE - 2017




These Images confirm all the settings and details of my laptop.

1 Like

i followed exactly same steps ..

but i couldn't update bios

->Auto update option is locked

used flash drive :
->firmware management option missing
->flash drive not found

Basically cannot update bios

1 Like

Here is some guide how to update bios.

1 Like

already tried. : )

1 Like

this also. Didn;t you get problem with a disabled Bitlocker what gived you some denied. Before you deleted windows?
HP support gived that link to me to fix bios or repai,update.

The next option could be downgrade a bios then you get maybe diffrent settings?

1 Like

I remember on some laptops example Dell. You need click some type button F2 or something when you seeing a logo Dell.
My friend a have dell laptop old from 2010.
I remember when I have problems with my AMD graphic card.
ALL team here with @Aravisian - all administration trrying help me and it was a hardware problem.
I changed graphic card gpu and Zorin what I remember always working without problems.
In theory - you can also asking https://support.hp.com/us-en/contact asking for advice.

1 Like