Installing Zorin with Security and Duel-boot Windows

I've been stuck for two weeks. I looked deep for a distro that would suit my purposes. I am an experienced Windows user, but not well versed in using command line. I trialled Arch and Debian based distros. I decided on Ubuntu based ZORIN as an entry point. Specifically, I need a very secure install of Linux to due to the draconian new legislation in Australia, giving the government powers to hack, confiscate, interrupt, hijack, spy and manipulate personal networks with little recourse.

[I use a Lenovo ThinkPad Yopa X390 which has UEFI and runs Windows 10, a SanDisk 128GB Ultra USB 3.0 Flash Drive & Samsung T5 500GB SSD]

First, I dual-boot installed Zorin. It worked. On a second boot, I got stuck on the GNU GUB 2.0.4 terminal. Boot repair did not work. Secure Boot, Boor Order changes and BIOS setting changes recommended from this site did not work. I wanted to encrypt the partition so that this side of the disk was safe. I could not try.

Second, I tried to install Zorin to my SSD drive. The intention was to have a dedicated install drive that I could encrypt and 'plug and play'. That worked. But it's ability to boot is a bit of a fluke, as in I don't know how I did it. When I boot the computer up, and put in the admin password, the PC automatically shows the graphical interface to choose the OS (not through the Boot Menu). Interestingly, I can launch the dual-boot Zorin from this menu now. But only when the SSD is plugged in. Grub must be correctly configured on this device. When I try to boot from the SSD in my Boot Menu, there is no movement. The Boot menu screen resets. Selecting 'Ubuntu' leads to the Grub terminal. I've tried the method of running commands to find and run the boot files through that terminal and it always ends with Windows being run.

The SSD was partitioned in Gparted via the USB Live Key of Zorin (which itself was flashed with Rufus on Windows). It has 3 volumes: a Fat32 100mb boot (EFI) partition (somehow this partition shows in File Explorer as an empty, writable volume which is annoying), an 8GB parition which I believe is the swap-area for Linux system install and a 200gb home directory -- the remainder is unallocated space.

Third, I tried to do the 'persistent Live Key USB' thing. Which also works, but doesn't have login and password protection outside the administrator password.

Every tutorial video, article and forum describes the processes slightly differently and I can't complete them without getting stuck. I am feeling very out of my depth, and I know there's no perfect solution to these things. But I know that what I am trying to do is common and it can't be that hard to achieve.

I don't want to get rid of Windows because I am a musician and need Ableton Live 11. This is unavoidable for me, and due to latency and CPU power, it needs to be on my hard disk.

Ultimately, I want a secure way to use Linux that protects my data, apps and networks from online and IRL threats. I am slowly familiarising myself with Linux and its terminal, but I can't seem to get it all right. One problem seems to cause another. Surely I a overthinking it.

Any and all help is enormously appreciated. Thank you so much.

Right off the bat, I do not recommend that you install Zorin OS as encrypted.
It may seem more secure (Ok it IS more secure) but that type of security is not really what you need and it can work against you.
Unless you work for the CIA or CocaCola, it really would do you more harm than good.

I am aware that Australia has taken some... interesting... approach to covid as of late. But encrypting your drive will not have any effect on that.

The protection afforded you by ROOT and your ROOT password are sufficient. If you wish to protect personal and sensitive files beyond that, I can teach you some very safe and effective (and easy) methods for doing so.

I recommend going back to the beginning, deleting the partition that you used to install Zorin OS as encrypted and reinstalling it the normal way.
Then we can take things a step at a time afterward to try to get things set up.

2 Likes