Intel Graphics driver shows Ironlake mobile which im used to seeing intel Hp

I pulled up your system specs here...

I am sorry to have to tell you this, but you can't game with this notebook, your SPECS are far too low. Not only do you only have 4GB of RAM, but you only have Intel HD graphics, you have no discreet GPU.

This is the reason why your system is restarting. The games are trying to engage 3D acceleration from a GPU that is not capable of it. I have a old dual core notebook that also had Intel HD graphics just as you do, and it also can't game, I've tried, and it failed me for the last time.

So, if you want to game, I'm sorry, but your going to have to buy a new computer. Make sure you choose a machine that has at least a bare minimum of a Core I5 6-core CPU, 16GB of DDR4 RAM, and at least a Nvidia GTX1060, RTX 2060 or better recommended.


1 Like

it makes no sense to me that could be possible since iv played ATS 1.32 on my old laptop when i had windows 10 installed ..i guess im gonna have to dual boot. but then again why is my graphics driver Ironlake mobile and not Hp graphics Manjaro and Pop os picks up the correct driver on live boot

Ironlake mobile is what im seeing as the graphics driver i checked in settings and about.. I downloaded Manjaro and Pop Os to check if it shows the same and both manjaro and Pop os does not show Ironlake mobile as the graphics driver they display hp Intel Graphics which i dont get why Zorin cant pick up my graphics driver

CTRL ALT T to enter terminal.

sudo apt install cpu-x

Enter Password...

Press Y when prompt. Once installed, click the :zorin: icon bottom of screen, then type CPUX. Click on CPU X to open. Take a screenshot of what you see, then post it here.

This is mine on my Zorin machine for reference.

Under Code Name, thats where we will learn for sure what your CPU architecture name actually is.

Some Linux distro's report information differently for some reason. CPU-X however will not lie about what it finds. It works by reading the hardcoded data, which is why it requires to be run at root, and asks for your password to run it, this is normal.



at graphics it shows Ironlake mobile instead of hp Graphics

So does mine lol. Don't worry about it, that is the name of the architecture for the Intel HD graphics.

Screenfetch...
Zorin OS 16 PRO Screenfetch Kernel 5.11.38

At the end of the day, the real point of this is, you have an integrated GPU, and they are not able to do 3D game acceleration. You say you have been able to play games on your machine via Windows10? Well, I have no idea how Windows manages to do that.

Cause these screenshots I have been sharing of my Star Labs machine, that Intel HD graphics won't even let me launch something as simple as Doom. :flushed:

I was doing a bunch of testing for science, hoping I could get gaming to work on it, and see if I could finally make the computer croak. But alas, it never provided me the opportunity to make it squirm.

So, I game on a real gaming machine. My MSI GE76-231 Raider Notebook.


its very strange cause iv played American truck simulator 1.32 and need for speed carbon with ENB sweetFx with no issue whats so ever did you try manjaro cause i have played need for speed carbon on manjaro game edition its just with zorin that i cant

Interesting! No I have not actually. The only Linux distro that I have run on that machine is Zorin. Interestingly, Linus from Linus Tech Tips was able to get Manjaro working for him out of the box, with the exception of his sound. He probably just need to install the drivers for that is all.

I am running POP OS on my MSI machine, its a gaming sentric OS, and works out of the box with Steam and with Nvidia drivers already installed. If Manjaro works, maybe stick with that. Or maybe try POP OS and see if that works for you?

i see your GPU shows intel Hp but mine only shows Intel Processor

thats how i got to play games on manjaro it installed all the drivers windows would install to stabilize the operating system i guess

Manjaro is a rolling release, it's possible they might have a better driver for the gpu. It can be kernel related.

You tried pop ? Did the game work on it ?

i tried pop os on a different hard drive and after updates and ect i installed playonlinux and installed need for speed carbon and it worked. im not really a gamer i just play games to pass some time im really hard into graphic design and video advert creation and embroidery..all my softwares work well on zorin its just games that doesnt work at all except for the games in the software store that works, plus i like zorin because its an elegant professional operating system not to complicated like others iv tried im fresh from windows and zorin suites me well i even got wilcom embroidery studio to work in zorin and after copying registry files from windows registry to wine registry i got corel draw to work but have some issues now im learning gravit designer. but as for other distros my software doesnt work doesnt install but on zorin it does work perfect even after effects with some winetricks tweeks

Have you considered dualboot POP/Zorin?

1 Like

no i have not, but i mite try it on an old drive i heard dual booting can cause issues in the long run

I think many forum members are dual booting Windows/Zorin.
Triple booting could be tricky but dual booting is quite common.

oh okay then i will try that

1 Like

@Alpha, maybe try this guide on zorin for gaming ?. PlayOnLinux i never use.

2 Likes

Ironlake Mobile is the Correct Driver. The difference is only made in which file it reads the source from.

3 Likes

cool will check it out