Internet broke after firmware update, X1 carbon

Installed zorin pro about two months ago, was working fine. This is on Lenovo X1 Carbon.
I got a request to update firmware v15 something - i forget to look closely, just following the prompt.

Now internet will no longer work.

The machine is a dual boot with windows 10. At first I could still connect to internet through Windows. Now that also no longer works...
So it must be a firmware issue?
Wifi DOES connect fine. Afaik there's no firewall blocking it.
USB tethering did work, now not anymore.

Question:

  1. How can I find the firmware version currently installed?
  2. How can I install the previous version?

update:
I ran a Lenovo update inside the Windows 10 tha came pre-installed on the device.
That fixed the internet issue for Windows. Zorin still doesn't connect to internet.
I found that the DNS points to 127.0.0.53 only.
When I add any other DNS in the Network settings screen, it doesn't get updated

update: adding

nameserver 8.8.8.8

at the TOP of etc/resolve.conf fixed it.

Now I just need to make sure it doesn't get deleted on restart

Have you put Google Primary and Secondary DNS server addresses in your Router? This saves having to put them in IP settings in each device.

Primary 8.8.8.8
Secondary 8.8.4.4

my router? You mean the physical external device?
Will that solve the issue of systemd-resolved not saving the nameserver?

When I add

nameserver 8.8.8.8

at the TOP of etc/resolve.conf the issue is gone.
BUT each time the laptop goes to sleep, it stops working and I manually need to enter it again.
Adding it via the UI (settings -> Wifi -> ipv4 -> "DNS") makes no difference, it gets deleted on-sleep each time.

This askubuntu thread may contain the answer to your problem. See which works best for you:

I ended up reinstalling Zorin