Issue with zindex of same application windows

On Opening multiple windows of application's like chrome, i'm unable to select the second window. For example if there is normal chrome window and another incognito window, how ever i try to select incognito it's now going there. but the selection is happening, but its not coming on top. With dbeaver and zoom also i faced this issue.

1 Like

Which version of Zorin OS are you using?

Zorin OS 16 core

So, Gnome, with Gnome-Shell.
Can you try reinstalling some packages to see if that helps to resolve?

sudo apt install --reinstall mutter gnome-shell zorin-os-desktop

I have tried this, but doesn't seems to work. I observed that it's not happening everytime, but when there are too many apps opened and if i move between
workspaces, then its happening.

Please have a look at this video for the issue - https://drive.google.com/file/d/1kVxr8t5R8jaRRq0n0XhRB-ZbdkvZn_sF/view?usp=sharing
Note: At 4 seconds I clicked on chrome, but it's not coming forward. Later I tried minimising download manager, then also it's not working.

Can you please provide the output of

snap list

and

flatpak list

snap list - output

flatpak list - output

None of the apps you are experiencing this problem with appear on either list, so I believe at this time, it is safe to assume this is not due to a sandboxing issue or Snap or Flatpak.

Which brings me back to mutter. The window manager. I will try to research this issue more.

Thanks for such a quick response.

1 Like