JetBrains CLion crashes whole session with proprietary Nvidia driver

I was really happy to see that Zorin bundles the proprietary Nvidia drivers by default, and at first glance everything seemed to work fine. However, I spend most of my day in JetBrains CLion, and no matter how I installed (snap vs via JetBrains Toolbox), it always takes down the whole user session within seconds.

I am not sure how to debug this. What I like about macOS is that it shows a "whoopsie" dialog when the system crashes, which lets me look at the source of the crash, as well as submit it to the developers. That would be a great thing to have in Zorin as well.

I have used the driver chooser (via the software updater app) to use Nouveau, and that solved the issue, but also ruined my performance. I also tried one of the older "tested" Nvidia drivers and that didn't fix the issue. FWIW, I cannot compare with a Wayland session because that crashes immediately during the login.

I haven't had any issue with my machine in Pop!_OS 22.04 or older Ubuntu versions, so I don't think it's a hardware fault.

Regarding the logs, you have a few options:

  1. Through the Help menu, or checking manually in the locations used by CLion.

  2. Launch CLion from the terminal to see any output as you use it. Note that this will likely produce a lot of output, much more than what is probably useful to debug this single issue, but it may help. Normally, when it crashes the last few messages will be about this.

  3. Run sudo journalctl -xe to see the latest messages produced in your system. This will again contain a lot of information, from multiple events happening in your system. But if you run this shortly after the crash happens you will be able to narrow down your search.

    An advantage of using this method is that it will open the journal in a pager, so you can type / to start searching. For example / and then clion or something similar will help to search for an error.

  4. Run less /var/log/syslog which again will contain a lot of system logs. Scroll all the way to the bottom (press uppercase G to scroll down immediately) and look for something interesting there.

1 Like

Hey, thanks to both of you for the hints.

I had already checked the syslog and the CLion log file, but couldn't really spot anything in there. I just had some free time and switched back to the proprietary Nvidia driver (535) because I wanted to try the journalctl thing...except that now I cannot reproduce the crash anymore.

Zorin OS originally picked the latest driver (550) but I did switch to 535 intermittently and still had a reproducible crash...strange. But also good. Now I am down to zero problems with Zorin :slight_smile:

Will report back if it ever happens again.