Kernel panic when shutting down

After the most recent update, it says kernel panic when I shut down my zorin 16 pro, see the picture below, how could I fix it?

And after suspension, zorin cannot recover, i.e., the screen stays black.


An older solution here:

sudo nano /etc/default/grub

Change to GRUB_CMDLINE_LINUX_DEFAULT="… initcall_blacklist=dw_i2c_init_driver"

1 Like

it just make the problem worse, I cannot boot my computer. It will stuck saying that there is no suspend buffer for PTM, see figure below

Not good.
Tap the tab or esc key at boot - at the Grub Menu.
Tap the e or yab key to enter the Grub editor. Remove the … initcall_blacklist=dw_i2c_init_driver parameter and just make it `"quiet splash"
Exit the editor and boot up.

sudo nano /etc/default/grub

Repeat the above action, then ctrl+x, y, enter

sudo update-grub

That should stop the immediate problem while we research this further.

quiet splash is the paramer I was using.

I guess there is some problems with my nvidia graphic card

have you tried "quiet splash nomodeset"?

yes, with "quiet splash nomodeset", the computer can boot, but cannot be shutdown

In your BIOS Settings are you set to RAID or AHCI?
Are you using eMMC or nVME SSD?

Can you try switching to the nouveau video driver and see if the computer panics at shutdown with that driver loaded?

It is mini pc nuc?

Some solved it with a kernel update:

Upgrade kernel-5.14.8
the problem does not occur.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.