Keyboard HP ZBook Studio 365 - NVIDIA DRIVER

Hi
I have an HP ZBook Studio x360 with nVidia GP107GLM [Quadro P1000 Mobile].

I've installed nvidia-driver-510 but sometime the system FREEZE...

Have someone an hint to resolve this issue?

Schermata del 2022-03-21 14-07-22

Thanks

Have you tried using the Nouveau (Open source) Nvidia drivers?

I've tried what Nouveau and the system works well... but....

I've installed UNIGINE Benchmark on Linux and on Windows... Under windows work in 30fps.... Under Linux the same benchmark 6fps.....

What can I do to setup correctly the graphic card?

Thanks

I've installed PPA repository and installed manually beta drivers but.... the system always freeze .....

Any hint????

Do you use Suspend?
Do you use a Chrome Based Browser?

Is Secure Boot Disabled in BIOS EFI settings?

Can you post the output of journalctl -b-1 run in terminal? You can use pastebin.com to post it here.

To download file txt with command result

mar 25 10:43:53 gbanti-zorin /usr/libexec/gdm-x-session[1407]: (WW) NVIDIA: '/var/run/nvidia-xdriver-5aedb310' Permission denied

mar 25 10:43:48 gbanti-zorin kernel: nvidia: loading out-of-tree module taints kernel.
mar 25 10:43:48 gbanti-zorin kernel: nvidia: module license 'NVIDIA' taints kernel.
mar 25 10:43:48 gbanti-zorin kernel: Disabling lock debugging due to kernel taint
mar 25 10:43:48 gbanti-zorin kernel: nvidia: module verification failed: signature and/or required key missing - tainting kernel
_
mar 25 10:43:50 gbanti-zorin kernel: nvidia_uvm: module uses symbols from proprietary module nvidia, inheriting taint.

These are the only two issues I see. For the first one, please see this post:
https://bbs.archlinux.org/viewtopic.php?pid=1909115#p1909115

For the second one:

It looks a bit more involved. I wonder if running the 5.8 kernel might resolve your issue.
If you would like to test it:

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Reboot, tap the esc or tab key to bring up Advanced options for Zorin and select the 5.8 kernel.
Boot into it
Once on the desktop, run

uname -r

and check that you are on 5.8 and not 5.13

Test...

The problem is this...
I'm trying with 5,8 kernel and my notebook work perfectly

Thanks :slight_smile:

Gianluca

2 Likes