Keyboard mapping Zorin Lite Lenovo G470

Hi everyone

I am a very newbie (Zorin seems me a great distro) here but with some experience with other Linux distro. So, I wish to leave this (old) notebook as a nice example that Linux is cool for everyone and works under low requisites.

I installed the Zorin Lite, version 15.3, in notebook Lenovo G470, manufactured in Brazil, so the keyboard is a Brazillian ABNT2.

When it was installed, I was using an external keyboard by USB, also a Brazillian ABNT2. Everything was working fine, except I did not test yet in its native keyboard, and with very stranger results when some keys are pressed.

For instance, in the console:
once pressed letter ‘u’ the output is 4,
once pressed letter ‘i’ the output is 5,
once pressed letter ‘o’ the output is 6,
once pressed letter ‘p’ the output is *,

once pressed letter ‘m’ the output is 0,
and so on.

The half of the keyboard is fully “crazy”, it is like a numeric keyboard is over some keys.

My tentatives to fix were:

  1. Try to run it in the console
    #!/bin/bash
    setxkbmap -model abnt2 -layout br

  2. I created a xorg.conf.d/ … with the following file:
    $ cat /etc/X11/xorg.conf.d/90-keyboard-layout.conf
    Section “InputDevice”
    Identifier “Keyboard1”

Driver “keyboard”
Option “XkbRules” “xorg”
Option “XkbModel” “abnt2”
Option “XkbLayout” “br”
Option “XkbVariant” “abnt2”
Option “XkbOptions” “abnt2”
Option “XkbOptions” “terminate:ctrl_alt_bksp”
EndSection

  1. I added also this file in /etc/X11/xkb/:
    90-keyboard-layout.conf

I think that in on these two files the “xorg” will be reading the additional configurations.

I tried to find some solution from Ubuntu, but, there are some comments only for Gnome (Unity, I think) in settings options, but thes options are not present in settings os
Zorin desktop.

Any guess? Well, in any USB the external keyboard works perfectly. But, its embedded/native keyboard no …

Pressing so keys randomly, I discover the red Fn key (at the side of Win left), which solved the abnormal situation. But it was pure luck and a random guess. I would like to solve it definitely, because in the next time under a new boot, this problem will back again.

I did not any tentative with any graphical application except the setting configuration from Zorin.

Thanks in advance.

ccs (Claudio)

This sounds like a Region and language issue to me. I recommend you check all your Language settings.
While you may have selected your language at installation, some other setting may have defaulted to English.
You might try

sudo dpkg-reconfigure locales

Initially, thanks for your answer.
I already generated these locales, but I am not sure. I think on some option of BIOS enabled and some keys enabled by hardware, i.e. press the Fn followed by another F (1 to 12)

i will be writing for any progress or discover. By the way, it is working now !!! Maybe forever ???

ccs

Let’s hope. :slight_smile:

Well until April 2023 - then it will be time to move to Zorin 16. :wink: