Keyboard + Mouse input issues after latest updates

Preface

Yesterday (November 9th), a number of updates became available through the Software Update app. I installed all available updates.

I primarily use this computer for gaming. So after installing and rebooting, I opened up Steam to play some (Proton) games.

Main problem

In all First-Person-Shooter games:

  • The ctrl key starts being randomly and automatically pressed. My character will repeatedly "duck" without me touching the ctrl key.
  • Mouse movement is very intermittent. It continuously gets "stuck" before "releasing" again so I can move.
  • I can hear sounds in certain games that seem to imply a key or scroll wheel is being registered repeatedly and very quickly.

Games this is most prominent in:

  • Quake Live
  • Doom Eternal

I haven't noticed the phantom keyboard input problem anywhere outside of playing video games... but I am noticing the mouse getting stuck while using other apps / the desktop - albeit to a much lesser degree.

This issue was not happening until I performed the most recent updates.

Troubleshooting

  • Both Steam (beta client) and all games are fully up-to-date.
  • I've run steam --reset and re-logged into Steam.
  • I've cleared the Download cache within Steam.
  • I've verified the integrity of each game I've played.
  • I've attempted running the game with my monitor's FreeSync both enabled and disabled.
  • I've lowered all of the in-game settings (disabled motion blur, chromatic aberration, etc).
  • I've tried all 3 modes: full screen, windowed, windowed borderless.
  • I've tried the following Proton versions: Experimental, 6.3-7, 5.13-6, 6.20-GE-1.

When I performed the Zorin software updates, I noticed that a number of them related to "NVidia", so I decided to check the Additional Drivers app to see if a new NVidia driver had become available. Surely enough, I could now switch from 470 to 495. I was curious if maybe these issues where related to the video driver, so I went ahead and did that. Sadly, this did not improve anything... in fact I think it introduced a new problem.

Secondary problem

When launching Steam, it is now completely black (cannot see any of the UI). The only way I can get Steam working correctly is if I open it in Big Picture mode, then exit Big Picture mode to the desktop.

My specs:

  • OS: Zorin OS 16 x86_64
  • Kernel: 5.11.0-38-generic
  • Monitors: 3 connected, with primary monitor running at 3440x1440@100hz via DP
  • DE: GNOME
  • WM: Mutter
  • CPU: Intel i7-4790K (8) @ 4.400GHz
  • GPU: NVIDIA GeForce GTX 1080
  • Driver: Tested in both 470.74 and 495.44
  • Memory: total 31988MiB

Any advice will be greatly appreciated!

Hi and welcome to the forum :slight_smile:

I do not play any game myself but I know some volunteers who are gamers. I will ask them to pitch in here to help you.
@Michel @Storm @StarTreker

1 Like

The problem is i am using Pop! OS and i don't use Zorin for gaming. If a update broke something i can't help

As for gaming, everything works here and have zero issues. I play games with full fps (Star Wars Jedi Fallen Order, Halo The Masterchief Collection, Mass Effect Legendary Edtion and so on). I too use the GloriousEggroll proton for steam and i use the GloriousEggroll runner for Lutris (i don't use anything else).

As for the nvidia driver, i don't understand why everyone has issues with 470 or 495 drivers. I installed everything manually on my system (downloaded the driver from the nvidia site and installed it) and i have again zero issues.

Steam launch great here too, no issues. Do you use .deb package or flatpak ?

3 Likes

I don't have these issues, so I can't comment on the specific ones. However, I can comment on your driver use. You said what version driver you were using, but you neglected to mention weather your using PROPRIETARY or PROPRIETARY TESTED.

And before you ask, yes there is a difference, and yes it makes a big difference which one you use. You need to be using the PROPRIETARY only driver...

PS: Yes, looks like I need to update to the newer Nvidia driver that has been released. But that requires a restart after, and I don't feel like it right now, another time perhaps.


1 Like

Hi @Michel and @StarTreker - thanks for the questions!

@Michel I am using the .deb version of Steam.

@StarTreker I am using just the Proprietary driver now. However, the previous 470 driver I was using was both Proprietary and Tested. See screenshot below:

3 Likes

Thank you for switching to PROPRIETARY. Trust me when I say this, people, including myself, have had loads of issues with the TESTED versions. Glad to see you are on a PROPRIETARY driver, that issue should be solved. You are stellar! :star2: