Keyboard Problem

So, When for some reason I need to suspend my computer, when I turn it on again, the keyboard just stops working and I need do reboot it or shutdown all the time( and I can't login when it happens)
I use caffeine to stop the auto suspend
But when I forget it happens it's annoying

Do you have xorg-input installed?

sudo apt install xserver-xorg-input-all

I don't know yet
I'll check and then I'll reply

Sorry, I didn't reply your comment sooner. But i do have this installed, but the "suspend" keeps deactivating the keyboard

I searched for somethings, but the only I get it's something related to i8042, I updated the grub and I put the the, etc. But it didn't work

Ok, can you try

sudo nano /etc/default/grub

Arrow key down to:
and add the parameter i8042.reset to it so that it looks exactly like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset"

Tap ctrl+x to exit, then the y key to say yes to save, then the enter key to save and close.
The terminal will revert to normal.
Now, run sudo update-grub

then test after suspend.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.