LAN without conection - RTL810XE PCI Express Driver r8169

Hello, I have searched for this issue before posting. I've also been reading a lot. I am able to connect to the Internet with a 1.5 mtrs RJ45 cord.
However when I try with a 30 mtrs cords, connection is impossible. (the same cord works perfectly with other computers a laptop with an intel i5 processor and a netbook with an Atom processor)
The system detects it but I get a generic IP for IPV4 is: 169.254.115.247 (sometimes I managed to get the correct one)
I have change everything I could in Connman.
I cannot connect to internet. I wonder if there is an incompatibility regarding the processor and the long cord.
I have checked on the Intel web site but the network device is quite old and there are only drivers for Windows XP

I am under AntiX Now, But I have tried with Devuan and many other distros under live sesions such as Linux Mint and Zorin and also HBCD (Hirens boot CD) The long cable doesn't work in this computer, though it works in 3 other laptops.

This is my system


Machine:
  Type: Desktop Mobo: MICRO-STAR model: G31TM-P21 (MS-7529) v: 1.0
    serial: <superuser required> BIOS: American Megatrends v: 4.7
    date: 07/28/2010
CPU:
  Info: dual core model: Pentium E5300 bits: 64 type: MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1203 min/max: 1203/2603 cores: 1: 1203 2: 1203

Hi, I am surprised you are getting 169.254.xxx.xxx as that is usually associated with Windows network problem. 169.254.xxx.xxx addresses means you can only access other computers on this same private network of 169.254.xxx.xxx which means no internet. Have you tried to manually assign a valid IP address?
Here in the UK, if a computer is on a Domain the IP address usually starts with a 10.xxx.xxx.xxx and subnet of 255.255.255.0. Personal computers running from home usualky have 169.168.xxx.xxx addresses and subnets of 255.255.0.0. What results do you get when opening the terminal and enter:

sudo lshw -C network

Also 30 metre cable is only just inside the length that Ethenet can utilise. Anything longer than 100 ft will not work.

Thank you for your reply, I indeed tried setting an IP manually but I didn't work, maybe because I didn't know how to set the correct one, according to the other devices. But I will try again and I will come back with that command result.

Cat5 or Cat6?

Cat6 is good from 120 - 180ft within the 10Gbps range, depending on the alien cross-link.

I would also set IPv6 to disable.

1 Like

Hi! there thank you for your reply I don't know what CAT6 is? I will search and return back in a couple of days.

Newer Ethernet standard, thicker cabling, faster speeds.

Cat5, Cat5e, Cat6 and Cat6e are tested good for 328ft - anything longer than that and you'll need a switch or powered component in-between the connection; kind of like a repeater.

Look on the cabling sheath, there should be some writing on it - one of them will be a CatXx spec. That'll just specify which cable.

Also take a look at both ends - what are the wire colors with the tab facing down?

Here in the US we use the B standard - which is Wor, Or, Wg, Bl, Wbl, G, Wbr, Br (White-orange, orange, white-green, blue, white-blue, green, white-brown, brown)

I believe the UK uses the A standard, which just swaps the blue / green wires to: Wor, Or, Wbl, G, Wg, Bl, Wbr, Br (white-orange, orange, white-blue, green, white-green, blue, white-brown, brown)

You could be inadvertently using a cross-over cable, which is A one side, B on the other. Roll over would be a complete reverse of what standard on one side, and the opposite on the other.

2 Likes
off@antix1:~
$ sudo lshw -C network
[sudo] contraseña para siloff: 
sudo: lshw: command not found

Cable doesn't say anything , but I have it specially done for outdoor use. Colors are properly set . It works with three laptops. And It used to work with a router to extend signal. I am sure it is not a cross over cable. I am in Argentina. Its colors goes from left to right like this: Light orange - Orange - light blue- Blue -Light green - Green - Ligth brown - Brown.
Wi Fi adapter is like this:
IP Adress XXX.XXX.100.11
IP Gateway XXX.XXX.100.1
Should I add the IP manually like that? Maybe changing the last numbers?.
I have Connman System Tray installed.

So connecting one router to another one? Just clarifying, introducing two routers will have a lot of secondary options to consider. If so, is the secondary router configured correctly?

Do you have any kind of RJ45 cable tester? With it being outside, are you certain it's not damaged in some way; or picking up interference from something? If it's not in a pipe (conduit), it very well may be damaged..

That - might be due to Antix, haven't used. But, assuming that command isn't in Antix due to the syntax error.

Hi, No. I meant the cable used to be connected to a router in the past. I said this in order to show you that It is not a crossed cable. Also the cable works in other laptops fine.
It doesn't work on this computer (tower PC) , I am thinking there is a lack of power (related to the cable length) or a problem in the Net Card which is onboard.

Gotcha, gotcha..

Yeah, might suspect NIC failure then.. What spec is the card that doesn't work; 10X, 100X (100Mbps), or 1000X (1Gbps)? Maybe also check the pins - had a desktop that kinda blew out a few pins one time lol..

At least with a tower PC you can pull out the NIC and check the edge connector and clean with isopropyl alcohol and make sure it is seated securly. Not so simple if it was a laptop.
If NIC is proven to be flaky, maybe replace with new card, or maybe a USB/network converter would do the trick, but not ever tried them myself.

2 Likes