Laptop doesn't boot after accessing HDD from another laptop

Hi! I'm not used to linux distro, so I may be missing some reflexes that would be obvious to others.

So someone asked me to retrieve pictures on an old 32bits eeepc. Tells me the thing was slow as hell, her brother installed zorin on it, still slow as hell, he got her a newer laptop and setup zorin on this one as well. On the eeepc are supposed to be pictures she wants to get back.

So, we plugged the eeepc's HDD on the new laptop, I then realized that there was a linux on the eeepc (which she forgot to tell me). Of course files were inaccessible, we put the HDD in the eeepc, and the thing won't boot anymore.

"It was fine this morning" she tells me. Okay, now it's not.

I run boot repair from a live usb of Zorin, get this pile of mess. Recommended repair didn't work, still stuck with "boot error" message after post. Tried a few different options (most of them being grayed out), to no avail. Gparted didn't help either.

Does anyone have an idea on how to fix this?

Thanks a lot!

I edited the titre for clarification and changed the category to General help.


It originally had Zorin OS 15.3 Lite 32 bit on it?


I'm not sure, I believe it was 14 core, but I really have no idea. I used boot repair with a 15.3 lite version however, maybe that's what you're seeing in the pastebin.

At first the laptop would just bootloop after post without any message, after bootrepair it says "Boot error" after post but that's it.

But the title is not what happened though. There's the old laptop (eeepc) and the new laptop. I took the hdd from the eeepc, plugged it in the new laptop, then put it back in the eeepc. That's when the eeepc stopped booting correctly.

1 Like

Actually the original title "opening the HDD" gives an impression that you disassembled HDD. I will change that to "accessing HDD" to be more precise. If you have any better idea, please let me know.


I do not understand. Why are you trying to boot that drive at all?
You are only trying to recover the Data (Pictures) from the drive.

Plug the drive in and mount it while booted into the Zorin OS that is functional. See if you can access the files in the file manager.
If that does not work, you can try plugging in the drive, mounting it, then running DiskDigger on the drive to extract unmarkered pictures in Recovery.


Thanks for the idea.
For some reason I cannot mount the drive. When I plug the eeepc HDD into the other laptop, I see the partitions in Gparted but cannot mount them.
I used the "Check" option on Gparted, it didn't help.

And that drive was slower than snails on Zorin OS Lite even. Sounds like the drive has been failing and has finally fully failed.
You may try using the testdisk program to copy a partition from the eeepc drive that is connected but not mounted to a safe working drive.


Mr Beren19, I noticed that you've changed the comment twice, could it be that originally there was ChromeOS installed on the eeepc HDD? Because if so then that might be the problem of booting.


I'm asking this because link of your print screen is addressing a certain "chronos" user, that's why I believe this is ChromeOS.

I also sometimes use ChromeOS and now attaching the files to Zorin, I also cannot reach some these partitions. I guess you have the same problem. If the images (the pictures) your looking for is not located at user "chronos" you will not be able to reach them. I guess they are locked somehow.

An option could be that you attach the HD as an usb and alter the grub settings on the PC. Perhaps then the Chromium bootings will be visible when rebooting.


It doesn't look good:

Only devmode is possible which will wipe all data. Similar situation with Google Android devices. Youngest forgot their security pattern swipes earlier today and only way round it would be to login to Google Account which would wipe everything! Fortunately they remembered the pattern.


I had a closer look at Boot repair log.
From Line 432 and below, I could see the transition of OS on this machine.

Windows XP -> Windows 7-> ChromeOS -> Linux

Without wiping/reformatting HDD in between.
I think the solution would be very difficult to find if not impossible.


Hi, really appreciate the time you're taking to answer.

I believe the original post was modified twice by a mod because the title was not intelligible enough (not english native here).

For the eeepc, it is not mine, just a friend's who even struggle with windows. Her brother installed zorin from windows 7 starter without really asking her, and when she inquired about the pictures, he told her it was alright. They are not in good terms so she'd rather ask me to solve this issue, but as you can see, I'm out of my league.

I don't think I have the skills to solve this without risking to mess something up.

Thanks for trying to help!

I have also taken a close look at the outrageously huge long, long, long list of code in there, and I had a headache at the time.

I have concluded, the only thing that can be done, is a full wipe of the drive, format it to GPT, and then install Zorin OS. Sorry, you won't be recovering that data. Chromebooks were designed by Google, and they want to make things as hard as possible.

I am sorry to say, your data is lost. If you could send the Chromebook to Google, save your data they might, more then likely, steal your data, and say they couldn't recover it, they would.

I repeat, to get back to a working computer, format to GPT, installed Zorin OS, and be done with it. Chalk it up to a learning lesson as well I suppose.

I have spoken


When I use ChromeOS I have to login using my google account.
My question, dear Beren19 is, did the user saved those pictures directly to the hard drive or to his/her google account because if it's the google account, then of course there are other ways throughout the web to obtain those pictures. If not then I'm afraid you have a problem.

BTW I also tried to reach the ChromeOS partitions using testdisk, but with no good result.

Yeah, I have no idea why just plugging the HDD in another computer messed everything so badly. But maybe it was doomed since the beginning with that botched install, on top of the failure of an OS that windows 7 starter already is.

This is definitely something that I can't solve it seems. Thanks for helping though, really appreciate it.

1 Like

She definitely doesn't have a google account, everything was on the hard drive.

Well, sorry to hear that.
Perhaps you can attach this drive as a live usb to an installed ZorinOS and update the grub, so that the usb gets recognized and make you able to boot it (you have to have EFI enabled in the bios though, because that's what's mandatory on my pc).

If've tried some other linux distrubutions and updated their grub but my experience is that ZorinOS is a very stable system and the grub always recognizes whatever I attach to it.

Again; and I am not trying to be difficult... But I do caution against solving the X Y Problem.
Booting the drive may make it Bootable, but being Bootbable is not necessary to recover the data.
Data recovery can be performed even on a Broken And Unmounted Hard Drive - I have done this many times, including as recently as this past week.