Laptop doesn't power cycle on shutdown or restart

I recently bought the asus tuf gaming a17 laptop and installed zorin. It was a process trying to find the proper uefi boot image for the live usb, then dealing with an under supported Realtek 1811 WiFi/ Bluetooth adapter. After finally getting that corrected, zorin updates and i loose my wifi again, but more troubling is the fact that the laptop will not completely power cycle for restart or shutdown. What i mean is the power stays on, though the os completed shutting down.

I googled this and found Ubuntu 12 and 18 had the same issue. I attempted the grub fixes of acpi=force and the acp=power_off to no avail. Any ideas would be appreciated. I also would like a persistent driver install so that i don’t have to redo my wifi adapter after every update.

Thanks for all your help.

Is there any indication like the Power Light being turned on? And also what is the bios version?

Asus bios v 3.09… the power light and screen both remain lit, though it’s a black screen

Does your Asus have an “advanced” tab in the BIOS?
Some say there is a Power Setting that needs to be disabled in the Advanced Bios Tab.
Others say logging out before shutdown seems to cause the notebook to shut down properly.

You can also look at

sudo nano /etc/systemd/system.conf

Scroll down to

#DefaultTimeoutStopSec=90s

Remove the # sign and change to 5 seconds so it looks like

DefaultTimeoutStopSec=5s

On Realtek driver with updates : Many of us feel your pain.

1 Like

I’ll check out those options… let you know how it goes. Thank you for the quick responses and taking the time.

Do you have Windows? A BIOS Update may fix that. Go here ASUS TUF GAMING A17 BIOS & FIRMWARE, select your CPU or BIOS Model, get the update. Note that there are two options. One is for the EZ FLASH UTILITY another is for Windows. If you don’t have Windows, download the EZ FLASH UTILITY version and watch this tutorial to flash it. It may solve the problems. Warning: Always Backup your Data. If the BIOS fails, you won’t be able to boot and you will lose your data(though you can go to a support center nand fix it there, but still).

Updated to bios 311, modified system.conf, turned off secure boot and fast boot, logged out prior to shutdown and still does not power cycle the screen or laptop itself

Oh god! Try dualbooting another linux like Debian or Ubuntu. See if that does it, if it doesn’t power cycle, your laptop has a weird issue… If it goes normal (i.e. it power cycles) then something is wrong with the Zorin installation process.

Out of curiosity, is this a used laptop? Just asking.

I’m sorry that I didn’t get back to you. I had posted to so many forums looking for answers that I lost track where I posted. It is a brand new laptop, with a fresh install of win10. Anyway, I found that the zorin firmware and an unsuccessful reinstall were to blame…it didn’t completely rewrite the files after a format I believe. Maybe I should have changed to fat and reformatted again before trying the install. It’s been a learning experience.

Does that mean you are all fixed up?

Not quite… now I’m hanging on the asus logo when i boot to zorin. It was booting fine until i installed the nvidia 460 driver. Thought i solved the usci error when i added the primary graphics option to the congig.d files, which stopped the errors, but hangs now.

If loading the Nvidia 460, have you tried adding “nomodeset” to Grub and updating grub after?

Every time i edit the grub file it hangs and throws errors… tried the asci=…asci_backlight=vendor, was going to try removing splash

It just hangs and never completes, right? Or do you get to a blank screen with a blinking cursor?

No… just hangs on the logoi actually have to use the live usb to edit the files. Thought wsl for windows would provide more functionality, but it’s Micro$oft

And you are Not logging in as Wayland, right?

From what you describe, it definitely seems the strongest lead here is the Nvidia 460 driver.
Which is partly why I asked about nomodeset, though you could also set to boot only in Intel or AMD, whatever it is you have, from Recovery mode and test if your graphics will load, then.
Otherwise, you may need to try a Different Nvidia driver.

Woah…i decided to try advanced options for zorin, booted in recovery! What is not loaded in recovery that is in normal boot? So the graphics card shouldn’t be the 460… ok. I think it was using the 440 driver. I’ll test and post. Should i try the nomodset to see if it’s that? The 460 is supposed to work for the 1660

I do not think ; and I am not the guru on this topic; I do not think that the issue is whether you have the absolute right driver for your specific hardware. 460 May Well be the right way to go- except at the point where the Linux kernel and Ubuntu both need to get caught up.
There is a reason why it is so easy to do a web search and find a picture of Linus Torvalds offering the One Finger Salute in Nvidia’s direction.
For compatibility (and in gratitude to Nouveau Drivers) Linux users sometimes have to jump through hoops just to get their Nvidia to work. Fortunately, it is not wildly common. And you may find the 460 Driver working fine if you upgrade the kernel to a higher version- that also may open up another can of worms, too.

What does NOT Load in Recovery Mode is a long list- but it is the most basic systems and the OnBoard hardware and drivers- so we know that means it is NOT loading Nvidia.

Wayland? You mean su or root? Why is it called that? Do i have to put the asci= before nomodeset?