Laptop locks itself again and again after being locked once

Today is the first time I've experienced this issue. I had to close the laptop lid once. When I came back and opened the lid I entered my password and then unlocked my laptop, but I could not see my taskbar and my mouse pointer was missing. After 2 seconds my laptop locked itself and I had to go through the process of entering my password again. But the same thing occurred. The laptop locked itself .My laptop cycled through this process of me unlocking and it locking itself about 5 or 6 times (I am not sure how many times I did this because I did not count). Luckily I was able to unlock it properly after going through that cycle many times this time the taskbar and the mouse pointer was visible. I took my chances and closed the laptop lid again to make sure that this problem was not just a problem that occurs once or rarely. But the second time I did it I only had to cycle through the process about 3 times.
Here is the output of inxi if you need

jeslin@jeslin-Satellite-L510:~$ inxi
CPU: Dual Core Intel Core2 Duo T6600 (-MCP-)
speed/min/max: 1197/1200/2200 MHz Kernel: 5.11.0-27-generic x86_64
Up: 4h 03m Mem: 1803.5/3803.7 MiB (47.4%) Storage: 298.09 GiB (4.4% used)
Procs: 203 Shell: bash 5.0.17 inxi: 3.0.38

I will be grateful for any help you give me and sorry if you feel like my English is bad English is not my native language but my school teaches me English. Hope you will have a great day.

1 Like

This sounds like the desktop is too slow to initialize upon unlock.
What happens if you use the Lock Icon from the app menu, prior to closing the lid? Does it repeat the behavior?

1 Like

No it doesn't.

Does that mean that I will have to switch to Lite?

That might solve the issue.

For a workaround, you may just hit the Lock Button prior to closing the lid from now on. :wink:

1 Like

Yeah looks like I will have to do that till I download lite. But why did it mess up now, it used to work properly.

You might try opening gnome-tweaks (sudo apt install gnome-tweaks if you don't have it) and disabling all gnome-extensions from the Extensions section in the left Pane.
Then test the Lid Closing (Tedious as it is) and see if that makes the problem stop. If it does, we know what the next step is...

1 Like

Yeah, that fixed the issue. Looks like i will have to move on to lite now.

Will there be a difference in disabling gnome and adding xfce (like what I think you did) and freshly installing lite?

You can try reinstalling the gnome-extensions if you want to stick with Gnome.

I may get in hot water on this but...

Not really. :expressionless:

If you like Dockbarx, you would need to add and configure it to resemble the Zorin Lite Desktop. I never use it and (cough) I uninstall it first thing. I can't stand the thing.

But... when Lite is released; if you installed XFCE4 in the meantime, all you need to do is run sudo apt install zorin-os-desktop-lite to install the full Zorin XFCE Desktop post release if you want.
Aside from dockbarx though... you still won't really see a difference.

1 Like

So you are saying that I can switch to lite with this one command? And oops I forgot that 16 lite was not released yet. I will probably only switch to lite when 16 lite comes out. In the mean time i will lock from menu or not lock at all.

1 Like

As far as User Experience goes - it is very nearly the same thing.
For the way I configure my own machine, you would be utterly unable to tell the difference at all.

1 Like

I am the complete opposite of you in that case. The first thing I got sad on when I disabled gnome extentions was the taskbar.

1 Like

The taskbar (panel) is still there... I just don't like the dockbarx extension. I find it clutter and superfluous.

You can see my panel with all my launchers. I just don't like dockbarx pinning launchers. On XFCE, it seems redundant.

  • By the way, re-enable your taskbar extensions - then test the lock screen lid problem. If it is still not present, we have narrowed down which gnome-extension is the culprit a little bit...
1 Like

I already did that and the problem still exists after I enable extensions. Got to get a good nights sleep now (actually it will be just 6hrs because I have a test tommorrow and I haven't prepared for it so I will have to wake up early and prepare)


You could install cinnamon de, which may provide a more stable solution until lite is released. It's also based on gnome but has a much better implementation. I use it on zorin 16 pro and have on core...i have never had an issue with the lid close action and redundant locking. Please be aware though that I'm running it on a newer machine, capable of modern day gaming.

1 Like

Hello Jeslin!

I am typing to you right now on a Intel Dual Core Pentium R P6200 CPU, 2-core 2-thread, integrated Intel HD graphics, and I am not having the lock issue that you are having. While I totally agree with Aravisian that the lite version of Zorin OS 16 will no doubt be less on your hardware, considering I am running the gnome version and not having that issue is a bit strange to me.

If you would rather your computer didn't lock at all when you closed the lid. Go to the software store, search for gnome-tweaks, install it. Launch Gnome tweaks, on GENERAL tab, turn off suspend when lid is closed. Also, go to Settings, POWER tab, and disable BLANK SCREEN.

1 Like

done it just now

1 Like

Good, here's hoping for a stress free time computing from now on. :+1:

1 Like

Yeah,I actually kind of like this more than the suspend feature.

1 Like