Login loop can't access

Hi guys, I have problem of login loop after rebooted my system.
I have latest Zorin OS Lite 15.3 all updated and running on a Vmware.
Problem seems start after installation of tigthvnc, because without shutdown the system as worked always, but after shutdown, continus loop and I can confirm password entered is correct.
I have tried to fix using ctrl+alt+F3 and command with sudo chown username:username .X authority but not work for me.

Anyone can help me?

A couple things you may try- just as you did with xauthority, check or change permissions of root /tmp

sudo chmod 1777 /tmp

You may also try removing and reinstalling the Login Manager (Either lightdm or gdm3).

ok thanks tomorrow I'll try it.
I have read also about .iceauthority can be useful?
about this command "sudo chmod 1777 /tmp" I need to login with ctrl alt f3 and simple paste it?
Instead for reinstall login manager on zorin os lite what I need to use?

Yes, you can paste in tty or terminal with ctrl+alt+v

You can use

sudo apt-get install --reinstall lightdm

and follow any prompts that it gives.

It may. One more thing to try.

Hi, I have solved entering with ctrl alt F3 and using commands:

  1. ls -lah (that show me .Xauthority and .ICEauthority owner is root)
  2. sudo chown [username:username] .Xauthority
  3. sudo chown [username:username] .ICEauthority

but I have also removed login password using:
4. sudo usermod -a -G nopasswdlogin [username]

Then I can enter on my desktop again.

Now I noticed a new problem, there are no more icons in taskbar, example: open firefox from start menu, no icon is present, also for File explorer or Terminal.