Messed up my Flatpak theme

So Monophony was playing up. By that I mean the font and Icon set was different. So I entered

sudo flatpak override --env=GTK_THEME=Breeze

In the terminal and now all my flatpak apps have switched to the Adwaita theme and icon set.

Is there a way I can reset the theme override somehow or do I have to do a complex process or reinstall Flatpak purging the config files? Thanks.

This command tries to replace the flatpak theme with Breeze. But do you have Breeze theme (KDE) installed?
You can run the same override command for a different GTK theme that you do have. For example:

sudo flatpak override --env=GTK_THEME=ZorinGrey-Dark

You can revert all changes with:

sudo flatpak override --reset

More here:

1 Like

That seems to fix the theme, however, I still get the initial issue (Font and icon not matching system).

Oh yes, and thanks for the command.

Have you tried the full directions here:

If that is not working, you can try using Flatseal to give Flatpak access to system themes.

Hmm... I can't see anything that says 'system themes' on Flatseal. Also I want the icon and font rather than the theme.

Also I want to copy the icon pack I want into my home folder, except most of the files in the folder are symbolic links, which the filesystem can't handle when performing file operations.

Mmm-Hmm... Maybe it's a KDE thing... restarting the computer seemed to fix the whole thing. Thanks for trying to help though.

And I've marked your first post as the solution as that fixes the Adwaita override.

Are you using KDE?


I wonder if @swarfendor437 or @337harvey may have better advice.

My answers here assume a user is on Zorin OS with a standard Zorin Desktop.
If you are on KDE, which does include Breeze, someone more familiar with the Plasma Desktop may be more helpful.

1 Like

I don't use Plasma anymore because it relies on systemd or remnants of systemd.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.