Microphone and speakers don't work in Zorin OS 15

I installed the Core edition of Zorin OS 15 on my laptop and the internal microphone and speakers no longer work. I also discovered that my headphone jack isn’t working either. I have an HP Envy x360 m Convertible with a 10th Gen Intel Core i5 and it says it has Intel HD Graphics. The mic is also by Intel and the speakers say they were done by Bang & Olufsen. I’m new to Linux and don’t know anything about how to fix these issues on my own so any help would be greatly appreciated.

Please try: How to fix audio not working - if that doesn’t fix it, then please post the output of lshw -c multimedia in terminal (ctrl+alt+t).

The other solution didn’t work. It appears that it’s not detecting my internal mic at all and has the speakers labeled as Dummy Output. Here’s the results from the terminal:
description: Multimedia audio controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 1f.3
bus info: pci@0000:00:1f.3
version: 30
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=sof-audio-pci latency=32
resources: iomemory:600-5ff iomemory:600-5ff irq:16 memory:6001120000-6001123fff memory:6001000000-60010fffff

Thanks. Unfortunately “product: Intel Corporation” doesn’t provide any specific information but here are some suggestions to try, in order:

  1. https://askubuntu.com/questions/1231326/hp-envy-x360-amd-ryzen-sound-setup
  2. https://askubuntu.com/questions/1252711/internal-microphone-not-detected-20-04-hp-envy-x360-ryzen-5-4500
    Both suggest working with the hdajackretask application which can be installed with sudo apt install alsa-tools-gui

So I’m following the instruction for the first link and when it opened menu for Jack retasking for HDA Intel sound cards it says “No codecs found. Sorry.”

All I could find on that was this: https://bugzilla.kernel.org/show_bug.cgi?id=206543 - indicating something along the lines of audio not going through the onboard codecs. Unfortunately, I have limited knowledge and experience in the sound area to know what that means.

As an aside, can you try alsamixer and unmute any item that may be muted on there?

I tried to use alsamixer and it said “cannot open mixer: No such file directory”. All I did was type alsamixer into the terminal which I presume how your supposed to do it. Did I maybe do it wrong?

Try sudo apt install alsamixer and then try alsamixer again.

This is what I got when I did that:
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package alsamixer

I think this should be

sudo apt install alsa-utils

That did not work either

Can you check your software updater settings against the pics here? Ignore the wine and cdemu repositories.

It had me set to US servers apparently. I switched it to main. Everything else looked the same as in the screenshots. Edit: I tried installing alsamixer again and it still didn’t wanna.

Try sudo apt update && sudo apt upgrade after that try Aravisian’s suggestion again. If you still can’t install alsa-utils then beyond missing repositories in the updater, I can’t think of what else it might be.

Yeah I still can’t get it to work

How about sudo apt dist-upgrade?

That also did not work. Should I just start looking for another distro at this point?

Try this. You can replace your sources.list file with the one from the installer. That should get you the correct repositories - barring any that you have added since installation.

The software updater issue is inexplicable. When I first installed Zorin it was on my desktop and that was the only machine out of four that had sound issues. After days of searching on the internet and a whole lot of trial and error, I found the that alsamixer fixed my issue. Some times these problems have simple fixes like that but it comes down to patience and troubleshooting. Or you can try other distros to see if they may work better with your hardware.

I think at this point it would just be simpler to just try other distros at this point. Thank you both for your help.

Depends on the build. Zorin is built off of Ubuntu, in this case, Ubuntu 18.04.
For different Distros that MAY offer a different hardware experience, Pop_OS!, MX Linux and a handful of others come to mind. Otherwise, a person can find themselves repeating the same base build with different names.
A very Quick Test on the basics might be to insert the Zorin installation media- Try Zorin, and test the Mic and Speakers to see if they work in that.